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GLOSSARY 

Explanations relate to the use of the word in this manual and other Hanover publications; the word or phrase 

may have other meanings elsewhere. 

ASE - AVL system editor 

AVL - Automatic Vehicle Location. Please refer to 7.5.3 AVL. 

console - former term for ‘controller’ 

(sign or driver) controller - on-bus device used by driver to select destination / advert / information details 

that will be shown on the signs (prepared using HELEN software) 

destination code - the number used to identify a particular set of destination signs (typically, front, side and 

rear signs).  NOT necessarily the operator's route / service number 

sign (or display) - equipment used to present text and graphics for viewing by passengers, usually located 

on the front, side or rear of, or inside, a bus 

glyph - the shape or appearance of a character 

GPS - Global Positioning System: satellite navigation system providing location and time information in all 

weather conditions, anywhere on or near the Earth where there is an unobstructed line of sight to four or 

more GPS satellites 

Key-lo - device used to transfer a HELEN database from a PC to a Deric+ or Eric++ controller 

LED - Light-Emitting Diode 

mimic - a tool within HELEN which gives a representation of how the sign will appear on the bus 

stroke width - ‘thickness’ of character stroke in the display mimic; e.g.: vertical stroke width is the width of the 

downstroke of the vertical component of a character (in dots) 
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1. Introduction  

1.1 Overview 

The Hanover Extended List Editor for destinatioN signs (HELEN) is a tool used to create messages and 

destination lists on a PC as they will appear on a Hanover sign. Using HELEN, all Hanover sign types can 

be programmed, from single sign systems to a multi-display AVL or GPS system. The information can be 

previewed on the computer or by linking the computer directly to it, viewed on the sign itself. Once a list is 

complete, it can be uploaded to an ERIC++, DERIC+, DG3 or EG3 controller or a dataloader.  

HELEN can also be used to customise signs: 

• The font editor allows the user to import fonts, edit existing fonts or create new fonts. 

• The graphics editor can be used to edit text and create graphic images for the signs. (Route numbers 

and destination / via point messages are composed as text in HELEN and then rendered as a graphic 

image by HELEN software). 

HELEN can be used both to program the sign information and also determine the way the information is 

presented on the controller, thereby giving significant flexibility.  

HELEN is a Windows-based program so it is useful to have some familiarity with this operating system. 

• Hanover recommends using Windows 7 or later. Although HELEN was initially developed on 

Windows XP, most features will work with previous versions of Windows (although Windows 95 will 

not support the USB Key-lo Dataloader). The only differences the user should see between the 

various versions of Windows are that default file locations have changed in newer versions and the 

screen design/style may look different to the screenshots used in this manual.  

• HELEN is compatible with 32- & 64-bit versions of Windows 7 or later. 

1.2 General 

The best understanding of HELEN software will be gained by reading the complete manual - but this is not 

always practicable for the user.  The document has therefore been written in a modular fashion in order to 

allow users to refer only to those parts of it they need: topics should thus appear relatively self-contained.  

However, there are several useful cross-references, both to other points within this manual, to other Hanover 

manuals and to external documents as appropriate.  Accordingly, when consulting this document using a 

pdf reader, it is helpful to have the 'Back' (or 'Previous') and 'Next' (or 'Skip' / 'Forward') buttons enabled to 

obtain maximum benefit from the intra-document cross-references.  For example, in Adobe Reader, press 

F8 to view the toolbar if it is not already visible.  Right-click on a blank section of the toolbar and, in the 

'Page Navigation' menu, please ensure that 'Previous View' and 'Next View' are ticked. 

Reference is made to the controllers using HELEN software and to the equipment used to display the 

information: detailed manuals are available for these from Hanover. 

Existing customers are strongly advised to always use the latest version of the software. This can be 

obtained on request. Using a newer version of HELEN with older controllers should not present problems 

but should any occur, they can be remedied: contact Hanover if necessary. 

Destination signs for buses and coaches are normally used on the front, side and rear of the vehicle.  This 

practice is so widespread that Hanover often uses 'front, side and rear' to describe equipment used in those 

positions.  However, it is important to stress that any sign can be used anywhere on a vehicle, subject to 

the relevant electrical / communications connections being made. 
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Note: the conventional print dialogue window will not appear when choosing the ‘Print’ option: options must 

be selected in advance via File → Print setup from the HELEN main screen. 

 

1.3 Scope of this manual 

This manual covers the installation and operation of the HELEN software. 

Manual covers 

Section 1 Introduction to the manual 

Section 2 Installation: preparation, installation from CD and HELEN setup wizard procedure 

Section 3 Getting started: sign size and address 

Section 4 Destination list database: creation of new folder/list and sign parameter editor 

Section 5 Destination codes and route codes: creation, edit or deletion of destinations 

Section 6 Saving and uploading destination lists: for ERIC, DERIC, DG3 or EG3 

Section 7 HELEN main window: Opening screen functions: file, options, route, help menus and 

buttons 

Section 8 Sign designer: opening screen functions and features 

Section 9 Hanover Technical Support: contact details  

Manual does not cover 

The destination or in-bus signs themselves: 

• The installation and service of the signs: for more details, please refer to the LED destination 

display - installation and service manual (ref. 540156)  

• Technical data sheet for individual signs: this is provided separately for each variant 

 
  

The screenshots used in this manual may not be exactly the same as those seen by the reader: 
variations are due to the new versions of Windows and HELEN the reader uses. With regard to 
this, please note that the terms ‘display’ and ‘console’ are no longer used and have been replaced 
by ‘sign’ and ‘controller’ respectively. The older terminology is reflected in some screenshots. 
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2. Installation 

2.1 Preparation 

Before beginning the installation, for which administrator’s rights will be required: 

• close down all other programs 

• back up any existing destination lists to another location on the computer 

• uninstall any existing versions of HELEN installed on the computer, otherwise database errors may 

occur. For more information, please refer to Appendix A: Uninstalling HELEN software. 

HELEN software v3.9 or later can be installed on the PC from the link supplied by 9 Hanover Technical 

Support. 

2.2 HELEN Setup Wizard  

No. Description Figure 

1 The ‘Helen Setup Wizard’ window will 

appear.  

Click Next. 

 

2 Select the directory location – the default is 

‘C:\Program Files\Hanover 

Displays\Helen\’.  

Then, click Next. 
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No. Description Figure 

3 Click Next to confirm that HELEN should be 

installed.  

 

4 The HELEN installation will start. 

 

5 Installing Key-lo Drivers; click Next. 
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No. Description Figure 

6 Key-lo drivers Installed; click Finish. 

 

7 When this window appears, installation is 

complete.  

Click Close to exit.  

 

8 Once installed, HELEN is added to the 

program list and a diamond ‘H’ Hanover 

icon is placed on the desktop.  

To open HELEN, double-click on the 

desktop icon.  

Note: the version number quoted will reflect 

what is installed.  
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3. Getting Started 

3.1 Signs 

All Hanover standard sign types can be programmed by HELEN. However, certain information will be 

required before a destination list database can be created. 

Note: High Resolution signs would need to use HERALD. For more details, refer to Herald – User Guide 

(ref. 542071). 

• Sign Type: LED Destination, Full Colour, Colour Route Number, Flip Dot, LED in-bus etc. 

LED Destination sign: 

 
 
Full Colour sign: 

 

Colour Route Number sign: 

 
 
Flip Dot Destination sign: 

 
 
LED In-bus sign: 

 

• Sign Size: This specifies the layout (or matrix) of LEDs or Flip-dots and is defined by the number of 

columns (width) x the number of rows (height), e.g.: 144 x 19. 
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• Sign Address: Each different sign must have its own unique address.  For OLED signs (using 

processor boards 7524 or 7611), this is set by the rotary switch found on the board.  For OLEMS 

signs (which deploy the 7766 board) the address is set using a link jumper.  Default settings in both 

cases are: front = 0, side = 1, rear = 2. 

3.2 Sign Size and Address 

There are two methods to provide the sign size and address: 

• either via the sign test from the controller (for LED sign systems only) 

• or via the silver label (for size) and sign processor (for address). 

The user may find it helpful to keep a record of the sign size and product number of each sign installed for 

reference: it will help if advice from 9 Hanover Technical Support is necessary later. 

3.2.1 1st method: From the Controller – Sign Test 

3.2.1.1 DERIC+ or DG3 

    
 

Step Description 

1 
Press F/E (  or ) until ‘Lock code:’ appears. 

2 
Enter 0101 using the arrows  and  (for DERIC+) or  and  (for DG3). 

3 
Press  or : ‘Show status?’ will be shown. 

4 
Press the UP arrow  or  once to display ‘Test signs?’. 

5 
Press  or : ‘Testing…’ will be displayed on the controller. 

6 
Press  or  to cancel the test. 

 

  

Second-hand / transfer vehicles may be configured differently.  If required, the switch (or link 
jumper) position can be changed to conform to the standard above. 

Remember that the setting must match the sign address specified in HELEN. 
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3.2.1.2 ERIC++ or EG3 

  
 

Step Description 

1 
Press the  key until ‘Lock code:’ appears. 

2  

Enter 9876 using the keypad. 

3 
Press the  key: ‘Show status?’ will be shown. 

4 
Press the UP arrow  once to display ‘Test signs?’. 

5 
Press the  key: ‘Testing…’ will be displayed on the controller. 

6 
Press the  key to cancel the test. 

3.2.1.3 EG4 

 

The sign self test function tests all the destination displays connected to the EG4 destination controller and 

can be used to help determine the source of a problem i.e. hardware, address settings or programming. 

 

The 4-digit lock code is 9876 by default or if a factory reset is performed. However, if 

an ERIC++ or EG3 is loaded with a list from HELEN, the lock code will be changed to 

0101 as HELEN has by default a lock code of 0101. 
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This function is accessed using the settings button ( ) on the front panel of the destination controller. 

It is shown as Sign Self Test: 

 

Selecting “Start” will start the sign test function.  

The following message will then be displayed: 

 

Selecting “Stop” will stop the sign test function.  

During sign self test, the destination controller sends a message to all the connected destination displays 

for them to show a repeating test pattern. This test pattern verifies that the destination displays and controller 

are communicating with each other and that for LED destination displays, the individual LEDs are working 

correctly. 

Each LED sign will show a scrolling message followed by an alternating test pattern (the content of the 

scrolling message is described below) whilst flip dot signs will show just the test pattern. There will be some 

variation in what is scrolled across the sign, depending on firmware, sign size etc., but the key areas will be 

the same.  
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3.2.2 2nd method: Silver Label and Sign Processor 

3.2.2.1 From the silver label (Pre July 2022): sign size 

An identity label on the rear of each sign will show the sign type and size. It is helpful to have this to hand if 

contacting 9 Hanover Technical Support about the product.  

 

Features Meaning Description 

Product no. Product number Identifies the display type.  

Position - Indicates where the sign is likely to be fitted on the vehicle. 

Type - Installation type. 

Our order no. Our order number Number used for internal use by Hanover. 

Your O/N Your Order Number Number used to identify the order for this sign. 

Your Part no. Your Part number Specific to each sign. 

Sign test character string definition 

LED signs will show scrolling text similar to that set out below, followed by a series of 

horizontal and vertical line test patterns: 

Example: OLED v1.15 (X1.15) #0 144x19 C=3D00 P=65/100 

OLED v1.15   =  the sign's base software type and version 

(X1.15)   =  application software version (Super-X) 

#0    =  sign address, set by the switch on the sign processor 

144x19   =  sign size in LEDs (number of columns x number of rows) 

(C=3D00)   =  for Hanover engineer 

P= 65/100   =  brightness of sign (100/100 is max (100%) while 10/100 is min (10%)) 

Sign 
address 
and size 
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Features Meaning Description 

S/N Serial Number Specific to each sign. 

End User - Is generally the ultimate operator of the vehicle. 

Builder - References the name/customer to which the product is shipped. 

Job reference - For the use of builder or end user. 

Manufactured - Date when the finished sign is available for shipment after all 

checks, tests and approvals are complete. 

Made in the UK - Shows the country of manufacture of the sign. 

Exx-yyR-zznnnn United Nations 

Standard Type 

Approval (EMark) 

number 

xx = country code. 

yy = regulation number. 

zz = regulation revision number. 

nnnn = approval certificate number. 

3.2.2.2 From the silver label (Post July 2022): sign size 

 

 

 

 

 

 

 

Features Meaning Description 

Product  Product number Identifies the display type. 

Position - Indicates where the product is likely to be fitted on the 

vehicle. 

QR Code - Serial number of product. 

Name - Name of product e.g. size, colour etc. 

Our Order Our order number Number used for internal use by Hanover. 

Your Order Your Order Number Number used to identify the order for this product. 

Your Part  Your Part number Specific to each product. 

S/N Serial Number Specific to each product. 

End User - Is generally the ultimate operator of the vehicle. 

Builder - References the name/customer to which the product is 

shipped. 
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Features Meaning Description 

Job ref Job Reference For the use of builder or end user. 

Produced - Date when the finished product is available for 

shipment after all checks, tests and approvals are 

complete. 

 

- WEEE (Waste Electrical and Electronic Equipment) logo = 

Dispose of appropriately. Do not dispose of with ordinary 

refuse – on all products. 

CE = conforms; can be sold in EU. 

RoHS = product contains no hazardous substances. 

UKCA = same as CE but for Great Britain. 

Exx-yyRaa-bb-

nnnn-zz 

The United Nations 

Economic 

Commission for 

Europe (UNECE) 

for automotive 

industry Regulation 

approvals mark 

xx = country code of certifying body. 

yy = regulation number. 

aa/bb = revision of regulation 

nnnn = approval certificate number. 

zz = approval revision number (if any). 

UNECE Reg 10 Exx-10Raa-bb-nnnn-zz 

Conforms to the Electromagnetic Compatibility 

requirements of the vehicles and electronic sub-

assemblies (ESAs) used in automotive industry. 

UNECE Reg 118 Exx-118Raa-bb-nnnn-zz 

Conforms to the requirements of the Burning Behaviour 

of Materials used in the interior construction of certain 

categories of motor vehicles. 

3.2.2.3 From the sign processor: sign address 

• 7524 or 7611 processor (for OLED signs) 

The sign address will be found by removing the rear panel(s) of the sign to reveal the processor. In the case 

of the 7524 or 7611 processors, the arrow on the switch is pointing to the address number. On the 7611 

processor below, the switch is showing sign address ‘0’. 
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• 7766 processor (for OLEMS signs) 

On the 7766 processor below, the address setting is provided by the position of the link jumper. Default 

settings are: front = 0, side = 1, rear = 2. 

 

  

address 
setting 
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4. Destination List Database 

4.1 Creating a new directory / folder 

HELEN uses a database which includes a list of destination codes; route filenames are based on these 

codes. 

Where more than one database is deployed, each should be stored in a separate folder as individual 

destination codes could be replicated in different databases. Storing one list per folder will avoid possible 

problems and confusion and also save on space. 

 

Files can be stored in any convenient folder although care should be taken if a shared machine is being 

used. 

For example, to create a new folder in ‘My Documents’, select Start → Computer → Local disk: OS (C:) → 

My Documents → New folder. 

 

Once HELEN is running, a new folder can also be created in the ‘Create New Destination List’ window by 

clicking on the folder button  that appears third from the right. 

  

Remember: each database must be stored in its own folder to avoid problems. 
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4.2 Creating a new list 

Step Description Figure 

1 To open HELEN, double-click on either the 

desktop icon or ‘Helen 3.11’ under ‘All 

programs/Hanover Displays’.  

The main ‘Destination List’ window will be 

displayed.  

 

2 Select File → New. 

Choose a folder in which to store the list, for 

example ‘My Documents’. Alternatively, 

create a new folder. 
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Step Description Figure 

3 Create a new folder within that folder and 

name it ‘Hanover destination lists’. 

 

4 Open that ‘Hanover destination lists’ folder 

by selecting it and then clicking Open. 

In the Input box ‘File name’, enter the name 

of the subfolder e.g. ‘My list1’  

and then click Save. The directory structure 

would then be: Hanover destination 

lists\My list1\. 

Note: If more than one list is used, it is 

important that each list is in its own 

subfolder. The directory structure for: 

• the first list would be Hanover 

destination lists\My list1\  

• the second list would be Hanover 

destination lists\My list2\ 

• etc. 

 

 

 

5 The ‘Sign Parameter Editor’ window will be 

displayed. 

Refer to 4.3 Sign Parameter Editor for more 

details. 
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4.3 Sign Parameter Editor 

4.3.1 Overview 

This is where the sign type, size and address details are entered. An example is shown below, detailing a 

bus with 3 signs fitted with standard default switch settings. 

Switch setting Position Type Size (W x H) 

0 front LED Destination sign 144 x 19 

1 side LED Destination sign 96 x 8 

2 rear LED Destination sign 32 x 17 

This information now needs to be entered into HELEN, one sign at a time.  

For switch setting 0 for example, the sign parameter editor has been configured as shown below: 

 

Note: To edit an existing sign configuration, choose ‘Load’ from the File menu in the Destination List window. 

Select the relevant list and click OK. Selecting ‘Sign config’ from the Options menu then delivers the ‘Sign 

Parameter Editor’ which, using the instructions below, allows the configuration parameters to be changed. 

Note: Do not click OK until all the required signs have been configured. 

 

 

4.3.2 Setting the 

sign address and 

size 
 

4.3.3 Selecting 
fonts for the 
sign 

4.3.5 Setting 
text fields and 
justification 

4.3.4 Masking 
area of the 
sign 
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4.3.2 Setting the sign address and size 

Parameter Description 

Sign Address and Size Sign Use of the up or down arrows: 

• to select the sign address 

• to add further signs 

• to move between existing signs within the destination list 

The number (switch setting) will change with each click of the mouse.  

Type Use of the drop-down list to select the type of the sign: 

 

Width x 

Height 

Use of the drop-down list to select the size (width x height) of the 

sign: 

 

From HELEN software V3.12.06 onwards, colour RN and Full Colour 

signs have the panel size in brackets as shown below. For example, 

a Colour RN of 160 x 19 will have two panel width options of either 

32 (for G3 range signs) or 40 (for G4 range signs). For more 

information, contact 9 Hanover Technical Support.  

 

There are 16 addresses available, numbered 0 to 15 (it will depend on the sign controller whether all 16 can 

be used) which are selected using the ‘Sign’ up and down arrows. 
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These will correspond to the actual address settings on the installed sign(s)1 unless a profile has been set 

up (refer to 7.2.1 Console configuration submenu: profiles). 

For example, if a particular sign has had its internal address setting set to 0, then the sign setting in HELEN 

should also be set to 0 when configuring the sign parameters. 

Once the address has been set, the sign type needs to be set. Click on the ‘Type’ dropdown arrow and 

select the type of sign that has been installed at this address. The dimensions of the sign can then be 

selected from the ‘Width x Height’ field. 

4.3.3 Selecting fonts for the sign 

Parameter Description 

Select General Fonts / 

Select RN Fonts 

Selected  

(Font names) 

Each font is named using the following structure hhwwstE1 

or hhwwstR1 where: 

• hh: height in dots 

• ww: maximum character width in dots 

• s: style i.e C for Condensed, N for Normal, B for Bold 

• t: vertical stroke width i.e 1, 2, 3 or 4 dots 

• E: character set – currently the Hanover European font 

set which includes Cyrillic and accented West European 

Latin Characters 

• R: font suitable for the route number field as the numbers 

and letters are all full height 

• 1: a character set (from 0-9 or from A-Z) 

Select General Fonts Select 

Standard 

Fonts 

The easiest way to select the most commonly used fonts for 

a given sign height is by clicking on the ‘Select Standard 

Fonts’ button.  

 

Individual fonts can be added or removed by highlighting the 

font and clicking the left- or right-hand arrows. 

Make default The range of standard fonts can be augmented by selecting 

a user-created font and clicking the ‘Make default’ button. 

These fonts are then incorporated in the automatic font-fitting 

process. Manual selection can also be achieved as described 

in 8.3.2 Font Selection. 

 
 
 
 
 
 
 
 
 
 

 
1 Unless the user has set up his own signs, the installation engineer would have provided details as to what these are. 
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Parameter Description 

Select RN Fonts Select RN 

Fonts 

There are a number of fonts specifically designed for the 

route number field to give full height capital letters. 

The fonts can be selected in a similar fashion, by clicking on 

‘Select RN Fonts’.  

 

Individual fonts can be added or removed by highlighting the 

font and clicking the left- or right-hand arrows. 

Make default Again, the list of standard RN fonts can be augmented by 

selecting the required user-created fonts and clicking the 

‘Make default’ button. Up to 20 standard fonts for each sign 

size can be accommodated. 

Fonts are required to produce the graphical image on the sign. Once a sign has been selected, only the 

fonts that will fit are shown. For example, a 144 x 19 sign has been selected which means only fonts up to 

19 dots (LEDs) high can be used – of which there are 20 different examples. Useful font sizes are 19 and 

17 as these make maximum use of the available space. Fonts 9 and 8 high are also useful as they allow 

two rows of text to be deployed separated by a blank row. As a rule, larger fonts are advisable for clarity 

and legibility reasons. 

The process in sections 4.3.2 Setting the sign address and size and 4.3.3 Selecting fonts for the sign will 

need to be repeated for each additional sign required.  

4.3.4 Masking area of the sign 

The ‘Masking’ function is not necessary unless there is a problem with the position of the sign. For example, 

if it is mounted low down and the bottom row of dots cannot be seen due to an angle, this section can be 

masked electronically and will not be available when the destination information is written to the sign. Up to 

four rows from the top and four from the bottom can be masked, and up to nine from each side by clicking 

the ‘Masking’ up and down arrows. Any adjustments will be shown immediately in the graphic representation 

of the sign shown at the bottom of the window. 

Remember that all vehicles using the same destination list will show the text on their signs, regardless of 

whether or not masking is necessary. It may therefore be necessary to product a duplicate list without 

masking if this is appropriate. Alternatively, masked signs could be allocated a separate address, thereby 

enabling just one list to be used.  

Note: Masking is only available for graphic messages and will not have any effect in Super-X. 

4.3.5 Setting text fields and justification 

Other tools which contribute to the layout of the text are found within the fields and justification section. Use 

of these functions depends on the size and shape of the sign, with any adjustments again being shown in 

the graphic representation of the sign at the bottom of the window. The ‘Width: Route’ setting determines 

the maximum space available for a route number. 

For example, if the sign is set to show a 16-dot high route number followed by two lines of text, the available 

space for this number can be adjusted. The ‘Height: Top’ function is similar but determines the space 

available for the top row of a two-line sign. It is generally recommended to accept the default values. The 

justification box simply sets the position of the route number either to the left or right of the text. Click the up 

and down arrows to toggle between the two. 
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5. Destination Codes and Route Codes 

5.1 Creating new destinations 

The sign parameters having been set up, the next stage is to add destination information. 

 

The ‘New’ button, now available on the above main screen, will be used for creating new destinations.  

When New is clicked, the following window ‘Enter Route Code and Name’ will appear. This window will 

show all the signs selected during the configuration process described in section 4.3 Sign Parameter Editor.  
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5.2 ‘Enter Route Code and Name’ window 

 
 

5.2.1 Inputting the destination code 

In the box marked ‘Destination’, enter the destination code e.g. the first destination on the list – say, 1. 

Each code entered must be unique within the list as this is the code to be entered on the controller by the 

driver. It can contain up to four alphanumeric characters if required. The ‘Destination’ box will automatically 

include additional zeros when the user clicks into another text box. In the figure in section, this has caused 

the ‘1’ to become ‘0000000001’.  

5.2.2 Setting the driver’s message 

The Drivers Message field is used to enter text that will be shown on the controller to indicate to the driver 

the destination corresponding to the destination code shown. Although this can be the same as the 

destination information itself, it is not always possible to fit all that information in. The driver’s message can 

therefore be an abbreviation of the destination or some other text that would indicate the actual destination 

detail displayed. Up to 16 characters can be entered, or if the message needs to be longer than this, further 

‘pages’ can be added by clicking the up arrow next to the message box. Up to 16 such pages are allowed 

for each destination and these will be shown sequentially on the controller. 

5.2.3 Inputting the sign information 

In the above example, the sign processor’s address should be set as follows: 

• Front sign: Sign 0 (144x19) set to address switch ‘0’ 

• Side sign: Sign 1 (96x8) set to address switch ‘1’ 

• Rear sign: Sign 2 (32x17) set to address switch ‘2’ 

 

 

5.2.4 Selecting 
‘Drop from’ option 
and using the Drop 
button 

5.2.1 Inputting the 
destination code 
 

5.2.3 Inputting 
the sign 
information 

5.2.2 Setting 
the driver’s 
message 
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Parameter Description 

Sign 0 

Sign 1  

Sign 2  

etc. 

• Enter the route and destination information into the text box or boxes.  

Example: 10 / Brighton / via Hove (three text boxes). 

• The first set of up / down arrows, directly to the right of the sign, is used 

to change the number of text boxes required. In this example, the way the 

sign is to be used required three boxes.  

Note: boxes available via these up and down arrows will vary according to 

the sign size.  

• The second set of up / down arrows is used to add extra text when more 

than one ‘page’ is required e.g. if additional via points are needed.  

Signs that use just a single line of text will show additional information over 

two or more ‘pages’; alternatively, the text can be made to scroll. 

In the case of sign 1, page 2 shows ‘via Hove’ so page 1 may contain the text 

‘Brighton’ for example. The number adjacent to the arrows indicates the page 

number.  

Note: Sign 0 is also the switch setting for the sign processor on the vehicle. 

5.2.4 Selecting ‘Drop from’ option and using the Drop button 

Parameter Description 

Drop from: / Drop The Drop button is used to save time when inputting destinations although is 

optional as all information can be entered directly. In 

• If ‘Front sign’ has been selected as ‘Drop from’ option: 

Once the text is entered into the front sign (Sign 0:144x19), it will be 

duplicated to the other signs and to the Drivers Msg. when the button marked 

Drop is clicked. All boxes are still editable before and after the information 

has been dropped. 

• If ‘Drivers Msg.’ has been selected as ‘Drop from’ option: 

Any information in the driver’s message box will be copied to the signs. This 

is a useful function as many signs may be installed; however, on clicking the 

Drop button, all information previously entered into this destination’s fields 

will be overwritten so care must be taken. 

 

5.2.5 Saving the destination information 

When the text boxes are filled and to save the destination information, click OK. 
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The ‘Preview’ screen below will be displayed after it has generated the signs. 

 

The preview screen shows, dot for dot, the image that will be created on the signs when the corresponding 

destination code is entered on the driver’s controller. It will also show the driver’s message (text only). The 

driver’s message preview will use the controller configuration parameters (refer to 7.2.1 Console 

configuration submenu: profiles) to show either one or two lines and to determine whether to convert to 

mixed case or leave in upper case.  

Note: old controllers can only show upper case text. 

• The single- / two-line setting is made in Options → Console config. → Select Profile → Modify → General. 

For more details, refer to 7.2.1.1 General. 

• Case options are determined by a setting in the Configuration file (Options → Configuration). For more 

details, refer to 7.2.5 Configuration submenu. 

Press OK to return to the Destination List window. Repeat this process until all destinations have been 

entered. Note that each destination will need a unique destination code: HELEN will not allow duplicates. 

 

If there is more than one page, the preview screen will show pages three seconds by default. This rate can 

be changed by moving the slider. Moving the slider to the leftmost position will actually freeze the current 

page; this may seem odd as it is moving towards the fast symbol but it does allow speedy movement through 

the pages until the desired page is reached – which can then be frozen. In addition, the cursor hovering 

over a sign will show the sign size and type.  

Check the signs. If editing is required, double-click on the sign to be changed and the following ‘Sign 

Designer’ window will appear.  

For more details on ‘Sign Designer’ window, please refer to section 8 Sign Designer. 

Once a sign has been configured (refer to 4.3 Sign Parameter Editor) that configuration applies 

to all signs within the same list i.e. if sign 4 is set to 32 x 19 Colour RN, then all sign 4s within 

that list will be 32 x 19 Colour RN. 
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When the required edits have been made, click Save & Edit. The preview screen will then appear, showing 

the changes made. When all signs are correct, click OK. The main destination list window will be shown and 

the newly-added destination will now be on the list.  

 

5.3 Editing an existing destination 

Double-click a destination within the Destination List window, or click the Edit button on a highlighted 

destination.  

The following ‘Edit Route Code and Name’ window will be displayed: 

 

Text editing 
fields 

Click to drop 
edited text on 
to sign below 

Click when 
editing 
complete 

Exit 
without 
saving 
changes 

Change font 
size and 
type 

To add the next 
destination, click 
New and repeat 
the process until 
all destinations 
have been added. 

The newly-added 
destination will 
now be on the list. 
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Both the destination code and the driver’s message can be edited directly from this window. Click OK to 

save any changes or Cancel to discard them and return to the Destination List window. Edit Signs will show 

the sign designer window. For more details, refer to 8 Sign Designer. 

To find a destination in a long list quickly, click on Route from the Destination List window and select Find.  

 

Any numerals or text or combination thereof entered in the ‘Find What:’ box will be found in list order, 

whether the search term is in the Route Destination or Drivers Message column.  

5.4 Deleting an existing destination 

Destinations are easily deleted via the main Destination List window. Select the one to be removed and 

click Delete. 

 

In the above example, code 0002 will be permanently deleted.  
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From HELEN V3.13 onwards, it is possible to select multiple destinations for deletion. A popup, which shows 

the number of files selected for deletion, will be displayed as follows:  

 

In the above example, items 0002, 0003 and 0004 will be permanently deleted. 

  

Deletion is permanent so make sure to select the destinations that should be deleted before 

selecting ‘Yes’ from the popup.  
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6. Saving and Uploading Destination Lists 

6.1 For DERIC+ or ERIC++ 

6.1.1 Transferring destination list to Key-lo 

Step Description Figure 

1 Plug your USB cable to the base station and your 

PC. The ERIC.BIN file will be sent from the PC to 

the base station.  

 

 

2 On the HELEN main screen, click the “File” menu 

and then select “Save Output File”.  

 

Note: If the database has not been previously 

saved, it will now be automatically saved and the 

following screens will then be displayed. 

 

 

 

 

 

 

 

Verify that the options selected are correct and 

then click OK. 

 

‘Check Route Files’ will check the details of the 

signs fitted against the details found in the route 

files. Any discrepancy will create an error list. 

 

 

 

 

Click OK to save the database. 

 

 

 

 

 
 
 
 
 

connected  
to PC 
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Step Description Figure 

3 On the HELEN main screen, click the “File” menu 

and then select “Send Output File”. 

 

 

 

 

 

 

 

 

 

 

 

The following “SendWrap” window will appear as 

shown. 

Note: Please make sure ‘KEYLO1’ is set in Send 

Port.  

 

4 Plug the Key-lo into the base station.  

 

5 The transfer will automatically start. When the 

light of the Key-lo turns solid green and the status 

bar on the computer screen turns completely blue, 

the transfer has completed.  

 

 

6 You can now remove the Key-lo from the base 

station. 

 

connected  
to PC 
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*Advanced options of ‘Save Output File’ window: 

• Controller code: Some features like Appendix D: Route Browse require the use of 10 digits but 

generally a 4-digit code will handle a list of up to 9,999 routes which should be sufficient for most users. 

However, if in doubt, unless the controller is very old, the controller code can be set to ‘10’ although it 

will slightly increase the size of the load file.  

An additional feature provides for the HELEN program to examine the list, determine if Route Browse 

is in use and, if so, select the 10-digit code setting automatically. 

• Data Loader Message: If an ERIC / DERIC controller is being used as a dataloader (from HELEN 

version 3.0) then the text entered here will be shown on the controller screen (this has no effect if a 

Key-lo is being used as a dataloader).  

Note: a DG3 or EG3 cannot be used as a dataloader. 

• Current File Size: indicates the size of the binary file and should show ‘0’ until an output file is created. 

• Compression: refer to 7.2.5 Configuration submenu. 

• Extra Data: If advert or AVL files have been created, select them here. They will then be included 

during the upload of the file. The Configuration box should be ticked if the parameters already set to 

configure the controller are to be sent to the controller. Note: these items will only become active if there 

are parameters to send i.e. ‘AVL – ASE’ will only be active if an AVL list has been prepared and an 

ASE.bin file exists in the data list folder.  

6.1.2 Key-lo loading to a DERIC+ or ERIC++ controller 

If there is a valid file stored in the Key-lo, the file transfer will begin automatically as soon as it is plugged 

into the controller. 

IMPORTANT: Ensure the controller is powered before inserting the Key-lo. 

Step Description Figure 

1 Plug the Key-lo into the 9-way D-type connector on the front panel of 

the controller. 

The Key-lo LED will flash green briefly and then become a steady red 

colour. Once the communication starts, the Key-lo LED will begin a 

sequence of flashes. 

 

 

 

 

 

 

 

 

• DERIC+: 

 

• ERIC++: 
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Step Description Figure 

 The following screens will be displayed on the controller: 

 

 

 

 

2 Once the LED on the Key-lo stays green, the Key-lo has successfully 

completed communication with the controller and should be removed.  

 

3 The controller will reset and depending on the size of the file 

transferred, the controller may take some time to process the file it has 

received. Wait until the controller has finished processing the file to 

ensure that the transfer was successful.  

 

• If file transfer is successful, the controller will either display “idle” 

or revert to last selected destination (if the previous and newly 

downloaded database both contain the same destination number). 

 

 

 

 

• If file transfer is not successful, the controller will display “NO 

DATA”.  

If this occurs, then either the file transfer did not complete 

successfully or the file transferred was not suitable for the 

controller. The Key-lo LED should also flash to indicate an error 

has occurred. 

A download should be attempted again. If this fails, then please 

contact 9 Hanover Technical Support.  

 

 

 

 

or 

 

 

 

 

 

  

Loading... 

 

 

Erasing... 

 

 

Waiting... 

 

 

Polling... 

 

 

NO DATA 

 

 

ORSETT 

--    *       ---- 0032 

 

Idle 

-- -- *       ---- ---- 
 

Busy... 
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6.2 For DG3 or EG3 

6.2.1 Configuring the USB stick for loading 

To ensure the correct data is loaded, an Eric.BIN file is saved on the USB stick using the directory structure 

X:\Hanover\DB\ (where X is the drive allocated by the PC to the USB stick). 

The table shows how to configure the USB stick: 

Step Description Figure 

1 Insert the USB stick into the PC and locate 

it.  In our case, it appears as REMOV DISK 

(E:). 

Note: The name and drive letter are 

variable and in this case, the drive letter 

allocated to the USB stick by the PC is 'E:'. 

 

2 On the USB drive, create a folder called 

'Hanover'. Open this folder and create 

another folder within it and name it 'DB'. 

Note: 'DB' stands for DataBase. 

 

3 The USB drive is now set up to download 

any ERIC.BIN file into the ‘DB’ folder.  

 

 

  

USB sticks sometimes fail: try another stick before assuming the problem lies elsewhere. 

The USB stick must be formatted to use the FAT32 file system.  
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6.2.2 Transferring the database to the USB stick using HELEN 

To load the database to the USB stick using HELEN, please ensure the USB drive is connected to the PC. 

Step Description Figure 

1 In the main HELEN window, click File → Save 

Output File As.. as shown. 

 

2 Verify that the options selected are correct and 

then click OK. 

 

‘Check Route Files’ will check the details of the 

signs fitted against the details found in the route 

files. Any discrepancy will create an error list. 

 

3 The ‘Save As…’ window will appear as shown (it 

may be necessary to browse to the USB folder 

→ Hanover folder → DB folder).  Ensure the text 

in the 'File name:' box is Eric (or Eric.BIN) and 

that the ‘Save as type:’ box has [*.BIN] in it. 

 

 

4 Click Save.  

Note: subsequent downloads will already have 

a file called Eric.BIN shown in this window: it will 

be overwritten. 

 

5 The database has been saved to the USB stick 

inside the DB folder.  Click OK. 
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6.2.3 Transferring the database from the USB stick to the DG3 or EG3 

Step Description Figure 

1 Insert the USB stick into the port in the front of the 

controller.  The DG3 or EG3 will automatically find, transfer 

and save the database as shown.   
 

 

 

 

2 When it has finished, a request to remove the USB stick 

will appear as shown. 

 

3 The DG3 or EG3 will re-boot once the USB stick is 

removed and will show the last inputted destination code. 

However, this number may not correspond with the new list 

loaded, in which case 'Bad destination' will then be shown: 

try inputting a number from the new list. 

If the controller is in 'remote' mode (i.e. the signs are being 

driven by an on-board computer), its screen will show 'Idle'. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Note that if the Eric.BIN file is corrupt, or no valid files can 

be found on the stick, the controller will show the following 

message 'Remove USB drive:' and will flash and beep 

continuously until the USB stick is removed, whereupon 

the DG3 or EG3 will reboot. This will not make any change 

to the current loaded file. 

 

  

USB: 
Loading… 

||||||||||||||||||||||||||||||||||| 
 
 
||||||||| 
 

USB: 
Please wait… 

 
 
||||||||| 
 

USB: 
Found                        ERIC.BIN 
 
 
||||||||| 
 

USB: 
Drive found 

 
 
||||||||| 
 

USB: 
Load completed 

Remove USB drive: 
 
 
||||||||| 
 

ERIC or DERIC-G3 V1.XX 
abcde 
||||||||||||||||||||||||||||||||||| 

 

HANOVER 
 

 
Rebooting… 

 
 
||||||||| 
 

USB: 
Load completed 

 
 
||||||||| 
 

USB: 
ERIC.BIN     Not Found 

Remove USB drive: 



                                                                                        HELEN Sign-editing Software – Operating Manual 

540125-18 page 43 of 199  08/11/2024 

 
 

7. HELEN Main Window - Opening Screen Functions 

 
 
 

 
 

This section covers the list of options available from the opening screen and gives a brief explanation of 

each.  

7.1 File menu 

 

7.2 Options menu 7.1 File menu 7.3 Route menu 7.4 Help menu 

7.5 
Destination / 
Information / 
AVL radio 
buttons 

7.6 Edit / 
New / 
Delete / 
Preview 
buttons 
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Menu item Brief description Refer to section  

New Create new database.  

Note: only one database in any one 

directory/folder. 

4.1 Creating a new directory / 

folder 

Load Load an existing database - 

Recent Files Display a number of recently used lists. The 

number of items displayed is set by 

MaxNumberOfRecentFiles in Helen.ini – the 

default is set to 10.  

Appendix B: HELEN initialisation 

file (helen.ini) 

Save Output File Create the file for the controller – usually Eric.bin - 

Save Output File 

As… 

Method to save the load file to a different directory 

or under a different name 

6.2.2 Transferring the database 

to the USB stick using HELEN 

Send Output File Load file into controller using Key-lo (via Save 

Output File window if file has not already been 

saved) 

6.2.3 Transferring the database 

from the USB stick to the DG3 or 

EG3 

Load Firmware This item will activate a file transfer program (the 

same one used to send the output file) which 

gives an easy method to update the controller 

firmware with a new version of Eric / Deric / DG3 

/ EG3 software should the need arise.  

- 

Print Print the contents of the signs 7.1.1 Print submenu 

Print Setup Set up printer for above - 

Export Export the list to a CSV file 7.1.2 Export submenu 

Import Import a list from a CSV file 7.1.3 Import submenu 

Regenerate Use existing text to re-create a sign image on a 

changed or new sign 

7.1.4 Regenerate submenu 

Regen. Errors View errors where the text will not fit on the sign 7.1.4 Regenerate submenu 

ViewRegenLock Examine pages on signs that have been locked 7.1.4 Regenerate submenu 

Language Choose operating language 7.1.5 Language submenu 

Exit Close HELEN - 
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7.1.1 Print submenu 

 

The Print function generates a hard copy of the contents of the signs. 

The Print Options window determines what is printed. 

Notes: 

• The usual Windows Print dialogue box is not shown. 

• For a large database, hard copy printing can use significant amounts of paper.  

Parameter Description 

Text Selects from just the front sign or driver’s message or will print out all signs. 

Pages Selects either every page for the sign(s) selected or just a single page. 

Grouping Will either group together all pages for a particular sign (Sign group) or will group 

together all the signs showing a particular page (Page group). 

Print to File Redirects the output to a file rather than a printer. This file can then be printed later if 

required. 

7.1.2 Export submenu 

The background to this feature is to able to Export the information contained in all the route files into a 

single Comma Separated Value (CSV) file. A CSV format will allow easy modification in a spreadsheet2. 

  

 
2 Open Office Calc is recommended as it does not automatically reformat the data e.g. the leading zeroes for a destination 
code will not be trimmed and the columns will be displayed in the correct width. Also, very importantly, the handling of 
quoted cells is handled automatically. 
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For example: 

HELEN – Destination List Preview 

 

 

 

 

 

By selecting Export from the File menu, the following window showing a list of sign configurations and 

available signs will be displayed. 

 

If for example, Sign 0 and then Export are selected, an “EXPORT.CSV” file will be created. Export will by 

default select the most common items but every item can be selected by clicking ‘All’.  

The range of routes to be exported can be set. 

The options for AVL and Information messages will be enabled if such files exist in the list. 

Refer to Appendix N: Export Submenu for more information about available export parameters. 
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7.1.3 Import submenu 

The import feature is effectively the reverse of Export. It will extract information from the CSV file and either 

update or create the corresponding route files. The importer will only import from columns that exist i.e. if 

there is not a valid column name, the importer will ignore any data in that column.  

When the import menu is activated, a file selection dialogue will display any CSV files in the folder. When 

the file has been selected, the program will scan the CSV file to determine the most likely separator being 

used (Comma, Semicolon or Tab) and the number of signs in the file.  

 

The above example shows that a comma delimiter has been detected along with three signs. The importer can 

import data to update any or all of the signs. Remember that only data correctly stored in the CSV file can be 

imported and any missing columns will leave the data in the list unchanged.  
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7.1.4 Regenerate submenu 

 
 

Regeneration is a useful timesaving feature. It can be used to change the type and / or size of a sign, or 

add new sign(s) to the system. Regeneration takes the sign text and size / configuration information from 

one sign and copies it into another sign(s) of a different size / configuration. 

  

7.1.4.1 

Signs to 

Regenerate 

 

 

7.1.4.3 Sign 
text source 

7.1.4.2 Range 
of Destination 
Codes 

7.1.4.4 Options 

7.1.4.5 
Case 
Change 
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Regeneration can be used for: 

1) Changing from a flip-dot sign to a LED sign 

In the Sign Parameter Editor’s Sign Address and 

Size section (refer to 4.3 Sign Parameter Editor), 

select the existing sign number to be changed and 

then select the new type. Click OK and then select 

‘Regenerate’ from the File menu. 

 

This example shows how sign 0 of destination 10 

can be updated. The default value ‘-‘ has been 

selected in ‘Sign text source’ which means that sign 

0 will take its existing text and place it in the newly-

selected sign 0. 

 

 

 

 

2) Copying data from an existing sign to a new sign; this avoids the need to re-enter the same information 

again for each new sign 

When creating a new database, initially placing all 

the information in just one sign saves time – for 

example, sign 0 (usually the front sign). This 

information can then be copied to any other signs 

in the system – including one newly-added.  

 

In this example, the information is to be copied 

from sign 0 (the source sign) so it has been 

selected in ‘Sign text source’. The information on 

Sign 0 will be copied to signs 1 and 2 which have 

been checked in the ‘Signs to regenerate’ section.  
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3) Altering the size or configuration of a sign; for example, changing the justification of the route number, 

the extent of any masking areas or the fonts used in a sign 

This is similar to above case 1). In the 4.3 Sign Parameter Editor, select the existing sign number to be 

changed. Sign configuration parameters (such as 

route number justification) can then be altered.  

For example, in Sign Parameter Editor, change 

the justification for each sign from a left to a right 

route number field and then select ‘Regenerate’ 

from the Destination List’s file menu to regenerate 

each sign. 

Again, the default value ‘-‘ has been selected in 

‘Sign text source’ which means that all three signs 

will take their existing text and place it in the 

corresponding newly-configured signs. 

Regeneration can also be used if, for example, 

only a large front sign exists but a new side sign 

and / or route number sign are then added. Data 

from the front sign can be used for regeneration 

on the side sign. The regeneration process will 

automatically extract any route number 

information and place it into a route number-type 

sign. 

4) Changing the case of the sign text; for example, changing all the text on the signs from upper case to 

title case (i.e. only the first letter of each word is a capital letter). 

7.1.4.1 Signs to Regenerate – Selecting the sign(s) on which to regenerate texts 

On the ‘Regenerate Signs’ screen, select the signs that will be taking the regenerated text by ticking or 

clearing the boxes in the top left of the screen. If only a single page is required on regeneration, tick the 

‘Single Page Side Sign’ box. This is useful if only the route number and destination from a front sign are to 

be placed in a side sign (i.e. no additional pages containing the via information from the front sign are 

required on the side sign). It is possible to regenerate only blank signs by ticking the ‘Regenerate Text on 

Blank Signs Only’ checkbox. This is useful is it is desired to restrict regeneration to newly-added signs. 

7.1.4.2 Range of Destination Codes – Selecting a specific range of destination codes 

By default, the entire destination list will be selected but the regeneration process can be limited to a specific 

range of destinations by selecting the ‘Start’ and ‘Stop’ destination codes on the top right of the regeneration 

screen. 

If AVL information is to be regenerated, then AVL must first be selected on the opening screen (refer to 5.1 

Creating new destinations) before selecting ‘Regenerate’ from the Destination List file menu.  

7.1.4.3 Sign text source – Selecting the sign from which to take the text 

Select the existing sign number the text is to be taken from by using the drop-down list box ‘Sign text source’. 

The default setting is ‘-‘. This means that for each sign selected in the ‘Signs to Regenerate’ section, the sign 

from which the text is to be taken will be the same one that the text is regenerated back to. This is useful 
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when only the size and / or configuration of a sign is being changed and is explained in the above examples 

1) and 3). 

7.1.4.4 Options 

This section allows some additional control over the regeneration process.  

Parameter Description 

Regenerate Text on Blank Signs Only As described, any existing text will be retained. 

Single Page Side Sign This stops multiple pages being regenerated on a side sign: only 

the first page will be included. 

Remove Regeneration Page Lock When a page has been edited manually, an automatic 

regeneration lock is placed on that page to prevent accidental 

removal. This option allows the page to be overwritten. 

Remove Unused Sign Data When a sign is removed from ‘Sign Configuration’, its contents 

will remain in the route files in case the sign is to be replaced 

later. This option will remove all traces of the removed sign from 

all the route files. 

Super-X This option will convert graphic text pages to Super-X (on 

suitable signs) which can save considerable space in the 

database if there is a large destination list. 

All Text This option will convert graphic text pages on a route number 

sign into text mode. Again, this is done to reduce the size of the 

database and is used for flipdot signs that cannot use Super-X. 

This option is greyed out by default and will only be active when 

‘enableTextMode’ in Helen.ini is set to ‘True’. 

Graphic This option will convert Super-X pages to graphic which can give 

more flexibility. 

Super-X Multi-Page This option will convert a list that has separate pages into Super-

X Multi-Pages. This will enable synchronisation between any 

static and scrolling pages. Refer to Appendix P: Working with 

Multipage Super-X. 

Note: Any graphic pages will automatically be converted to 

Super-X. 

7.1.4.5 Case Change 

Parameter Description 

No change Leaves the case status as it is. 

UPPER CASE This allows the case of a regenerated sign to be formatted in upper case, lower case 

or title case (title case is where the first letter of each major word is a capital letter). 

If ‘Title case’ is chosen, there is a list of exceptions such as by, of, under, upon, via 

etc. which can be used (and added to) to exclude certain words from the title case 

formatting. The ‘Use exceptions’ checkbox becomes active if ‘Title case’ is selected; 

when ticked and OK is clicked, the exceptions list is shown. 

Lower case 

Title case 

Use exceptions 
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7.1.4.6 OK button – Starting the regeneration process 

Check and configure any required regeneration parameters as detailed above, then click OK to start the 

regeneration process.  

The regeneration process will only regenerate the text content of the signs. 

Although most signs only comprise text, HELEN does allow hand-drawn images3 to be included. However, 

HELEN will only regenerate text content because the results of regenerating such images, particularly if the 

sign size has been changed, will in most cases be unpredictable and visually undesirable.  

When adding hand-drawn images to a sign in the sign designer, the regeneration lock will automatically be 

selected for that page. This will prevent the inadvertent regeneration of any signs that include such content 

(and thereby its corruption) – refer to regeneration lock in 8.2.4 Options menu. However, this can be 

overridden before regenerating by ticking the ‘Remove Regeneration Page Lock’ box. Note that this will 

mean that any hand-drawn images in the sign will be lost and will need to be added back in manually after 

regeneration.  

7.1.5 Language submenu 

 

This feature offers the user a choice of language in which to work. Select the relevant radio button and click 

OK. 

 
3 Including any images created in bitmap format 
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7.2 Options menu 

 

Menu item Brief description Refer to section 

Sign config. Select sign type and parameters 4.3 Sign Parameter Editor 

Console config. Select parameters that affect the controller 7.2.1 Console configuration 

submenu: profiles 

Console edit Edit the configuration parameter string directly 7.2.2 Console edit 

Fonts Edit and create user fonts 7.2.3 Fonts submenu 

Advert In-bus LED sign: ‘Next Stop’ or Advertising Info 7.2.4 Advert submenu 

Configuration General configuration 7.2.5 Configuration submenu 

7.2.1 Console configuration submenu: profiles 

 

HELEN provides a method for changing the configuration parameters of the controller in order to make 

additional features available: these are outlined in the following sections. Different settings can be applied 

to these features with different combinations saved as particular profiles. Up to 16 profiles can be configured.  

It allows a different profile to be set for each of several different 'sets' of vehicle signs - using just one 

database. 

In the Destination List window, select Options → Console config. as shown above. 
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The following figure showing the 'Edit Profile' window will be displayed: 

 

Profiles appearing in bold are sent to the controller where each can be selected by assigning a value in the 

range 0 to 15 to the 'PF' parameter in the 'System' configuration menu4 of the controller.  Only profiles 

marked by a bold number are sent.  A profile should always be set in HELEN. 

• If no profile is set in HELEN, the last-used settings for the controller are deployed instead. 

• If no profile is set in HELEN, and the controller has not previously been used (or has been reset to 

factory settings) the controller will have only limited functionality. However, profiles can be set 

manually on the controller - see the relevant controller manual for details. 

• If no profile has been set in HELEN, the default profile in HELEN can be activated by selecting 

Options → Console config. and clicking on a profile number (usually '0'). This will cause the profile 

to be activated and its number to be shown in a bold face. 

Parameter Description 

Edit* Modify Refer to ‘Modify’ below. 

Clear Refer to ‘Clear’ below.  

Copy Allows to make a copy of an existing profile. 

Paste This will paste a copied profile onto the selected profile.  

Modify Opens the ‘Configure Controller Profile’ window for the selected profile. Refer to 

7.2.1.1 General. 

Clear Clears all the parameters (i.e. settings) of the selected profile.  

OK Accepts the values for each profile parameter (set these via ‘Modify’) and returns to 

the Destination List window. 

Cancel Cancels any changes made and returns to the main Destination List window. 

*Profiles can be edited by either clicking on the ‘Edit’ menu on the taskbar or by right-clicking directly on the 

profile. 

  

 
4 This may require a software upgrade of the controller to increase the maximum number of profiles to 16. 
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7.2.1.1 General 

 

Parameter Description 

2 Line Display Normally the controller will show the driver's message on the top line of its screen and 

the current operating status on the bottom line. Selecting '2 Line Display' uses both 

lines for the driver's message and does not show the status. 

Remote Enable remote control of the controller, e.g. by the on-board computer. Note that the 

required protocol must be assigned to the communications port (refer to 7.2.1.7 Ports). 

Driver Select the messages to be shown on the controller from the dropdown list where '' 

uses the drivers messages (default) and '0-9 and A-E' use the messages shown on 

the sign with that number. This can be deployed where it is useful for the driver to be 

able to see exactly what is viewable on the outside of the vehicle. Note that if the 

destination sign messages have been generated using Super-X, this feature will not 

work. 

Type Select the type of controller from a dropdown list. This will set the parameters used to 

determine its basic functionality. Alternatively, these parameters can be set directly 

using the Advanced tab (refer to 7.2.1.2 Advanced). 

• User defined: Any features required will need to be selected using the Advanced 

tab. 

• Standard: The standard configuration allows selection of destination and 

information messages. This is done by entering the relevant code on the 

controller's front panel. 

• Route Browse: The destination is selected by first entering the route number and 

then browsing through the list of destinations on that route using the controller 

keypad.  The information messages are selected as normal. Refer to Appendix D: 

Route Browse. 

• Route Number Only: Only route numbers may be entered. 

• Advert Only: Only advertising messages can be selected. 

Language Select the language that the controller will use from the dropdown list. 
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Parameter Description 

Lock Code Certain controller operations are only available to those who know the four-digit lock 

code. 

Name This is an optional field when using the controller as a dataloader, for entering a name 

for the destination list, comprising a maximum of six alphanumeric characters. It will 

appear on the controller front panel for identification. 

OK Accept the parameters' values shown in each tab and return to the main window. 

Cancel Cancel any changes made and return to the main window. 

7.2.1.2 Advanced 

 

The Advanced tab parameters are set automatically when one of the preset types is selected from the 

General tab. However, they can be set manually if required. 

Parameter Description 

Timed Update With a suitable Eric+, DG3 or EG3 controller (not Deric models) it is possible to load a 

new destination list while the existing one remains in use until some pre-determined 

time and date.  At this point, the new list will replace the old one. Timed update will 

have the same value in all profiles. This feature will require a Real Time Clock to be 

installed in the controller. 

Route Browse The destination code is selected by first entering the route code and then browsing 

through the list of destinations for that route using the controller keypad.  The 

information messages are selected as normal.  This option cannot be deployed 

simultaneously with Destination + Route Num.  Refer to Appendix D: Route Browse. 

Destination Select and show destination messages by entering a destination code.  This option 

cannot be deployed simultaneously with Route Browse. 

Information Select and show information messages by entering an information code. 

Advertising Select and show advertising messages by entering an advert code. 
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Parameter Description 

Route Num. Select and show a route code by entering the route number. This option cannot be 

deployed simultaneously with Route Browse. 

Reset Settings This controls the values the operational parameters take after a reset or power-on. 

The effect of this control depends on whether 'Remote Enable' (RM) has been set and 

is explained in more detail in the controller manual. 

Extensions This is a text box which enables the inclusion of additional features through 

configuration parameters not provided by the standard configuration window. 

Note: The configuration parameters can be found in the appropriate controller manual 

(Appendix: Configuration code options).  

Scroll Page 

Time 

This will set the time that a Super-X scrolling page is allowed to scroll. This has a 

special value of 0.0 when it is required to synchronise a scrolling page to a change in 

page. From HELEN V3.13, the previous method, which required manual insertion of 

‘\rep1’ statements and setting this value to ‘0.0’, has now been superseded by 

Multipage Super-X (Refer to Appendix P: Working with Multipage Super-X).  

7.2.1.3 Destination 

 
 

Parameter Description 

Round Trip Includes a prompt for 'out' and 'return' destination codes which alternate each time a 

particular controller key is pressed. 

Browse Allows the destination code to be selected by browsing the driver's destination list. 

Confirm Browse Normally the browsed destination is automatically selected after approximately 15 

seconds, or when the controller F/E key5 is pressed.  However, it is sometimes a 

requirement that the driver should positively accept the destination.  If this feature is 

checked, a prompt for confirmation will be shown and the destination only accepted 

when F/E is pressed. 

 
5 Certain controllers have separate F and E keys: the E (enter) key is used in such cases. 
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Parameter Description 

Dest. size Determines the number of characters used for the destination code; normally this will 

be four but, if required, it can be extended to five or six. 

Blank Code The destination code of the message that will be presented in place of an otherwise 

blank display. For example, if a non-existent code is selected or the controller is set to 

an idle state. 

1st Page Set the desired duration in seconds for the first page of a destination message.  Note 

that the actual duration is constrained by the number of signs and the size of the 

message: graphic text messages take longer to send than Super-X text messages. 

Other Pages Set the desired duration in seconds for pages other than the first page of a destination 

message.  Again, note that the actual duration is constrained by the number of signs 

and the size of the message. 

7.2.1.4 Route Num. 

 
 

Parameter Description 

Confirm Browse This is the same option that appears on the Destination tab. Refer to ‘Confirm Browse’ 

parameter in 7.2.1.3 Destination. 

Route Number 

Characters 

The route number field may use any of the characters in the list 0 to 9 and A to Z.  

However, if it has been decided that certain characters will not be made available, they 

can be removed from this list.  Note that this only affects the route number field and 

only then when set by the driver using a controller operating in programmable route 

number mode.  No preset destinations or route numbers can be altered using this 

feature – i.e. it does not restrict the characters available when programming the 

database. 
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7.2.1.5 Information 

 
 

Parameter Description 

Hide Information If this is checked, the prompt for the information code will require the correct lock code 

before being issued. 

All Pages Set the desired duration in seconds for each page of an information message.  Note 

that the actual duration is constrained by the number of signs and the size of the 

message. 

7.2.1.6 Advertising 

 
 
 



                                                                                        HELEN Sign-editing Software – Operating Manual 

540125-18 page 60 of 199  08/11/2024 

 
 

Parameter Description 

Hide Adverts If this is ticked, the prompt for the advertising code will require the correct lock code 

before being issued.  (Advertising must be selected on the 'Advanced' tab to tick / 

untick this option.) 

Number of LEDs Number of in-bus LED signs 

The number of in-bus advertising LED signs can be changed from the default of 1 by 

setting this parameter.  A value of 0 disables the transmission of advertising messages 

although it is still possible to select them from the controller. 

7.2.1.7 Ports 

 
 

Parameter Description 

DERIC+ Defaults / 

ERIC+ Defaults 

Default settings for DERIC / DG3 or ERIC / EG3 controllers 

Most applications use the controller's default settings automatically so no 

adjustment is necessary here. 
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Parameter Description 

Port 0 

Port 1 

Port 2 

Port 3 

Port 4 

Port 5 

Protocols 

However, for situations where a controller is operated remotely to drive the signs, 

the customer will be advised which protocol to use: it can then be selected from 

the dropdown list. For all other applications, the settings should not be changed 

and the default will be used. 

Dropdown list of parameters: 

Parameter Description 

* Setting unchanged 

- Disabled 

SIGN Hanover display protocol (RS485)  

Note: Deric controllers – port 0; Eric controllers – port 1 

DIAG Diagnostic tasks (RS232) 

TERM Terminal remote control (RS232) 

etc. Many other protocols can be used in specific circumstances – 

contact Hanover for more information.  

 

 

 

7.2.1.8 Signs 

 

The functions on this tab are used to change the relationship between the physical sign switch setting and 

the sign setting contained in the destination list. 

Do not use the same protocol on more than one port: the results are 

unpredictable. 
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a) Parameters for physical sign switch positions  

Parameter Description 

Switch 0 

Switch 1 

Switch 2 

Switch 3 

Switch 4 

Switch 5 

Switch 6 

Switch 7 

Switch 8 

Switch 9 

Switch A 

Switch B 

Switch C 

Switch D 

Switch E 

For each switch setting in the display itself, select the sign defined in HELEN from 

the dropdown list: 

Parameter Description 

- Disabled 

* Default: Automatic assignment (physical sign uses data for 

corresponding database sign) 

0-15 Destination sign selected 

RN Selects a separate independent sign, showing an operational 

reference set manually via controller 

HANCIS On-board Hancis selected 

HTC On-board HTC selected 

@ In-bus advertising sign 
 

b) Saving space by sign redirection 

Normally, there is a one-to-one relationship between the sign settings in HELEN and those in the actual 

sign itself, i.e. the information in the database for sign 0 will be sent to the sign with switch setting 0.   

Considerable space can be saved by sending the same information to two or more signs, e.g. if the rear 

sign (say, switch setting 2) is exactly the same size and requires exactly the same information as the front 

sign (say, switch setting 0).  

 

The above figure shows how to direct sign 0 in HELEN to the physical signs with switch setting 0 and 2. All 

the other signs are unaffected. 



                                                                                        HELEN Sign-editing Software – Operating Manual 

540125-18 page 63 of 199  08/11/2024 

 
 

Note: this could also be achieved by setting the address switch in both signs to position 0 and leaving all 

items on their default setting; however, this will interfere with the status response as both signs will try to 

send their status at the same time. This is therefore not recommended. 

c) Reducing the number of destination lists by using profiles 

If there are several vehicles with a different quantity and size of signs fitted, then a destination list could be 

generated for each bus type, i.e. where each type contained much the same database information but with 

different sign configurations. An alternative is to create one destination list with all the destinations and all 

the signs that are fitted across all the buses, using the Profile feature. 

This feature makes it easy to manage a fleet of vehicles fitted with many different signs but all using the 

same destination list - but it is not designed to save controller memory space. That can be done using 

container files (refer to Appendix C: Container Files). 

Example: 

The fleet consists of: 

• Type 1 – 32 x 16 front route number 

• Type 2 – 160 x 19 front sign + 32 x 17 rear route number 

• Type 3 – 192 x 19 front sign + 96 x 8 side sign + 160 x 17 rear sign 

Let the signs in the HELEN database be allocated the following values: 

HELEN sign setting Sign 

Sign 0 192 x 19 

Sign 1 160 x 19 

Sign 2 160 x 17 

Sign 3 96 x 8 

Sign 4 32 x 17 

Sign 5 32 x 16 
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There are now two options: 

Option Description 

1 The configuration is left at the default setting (one-to-one mapping) and the actual sign settings 

are set as follows: 

 Sign Switch Setting Sign HELEN Sign Setting 

Bus Type 1 5 32 x 16 5 

Bus Type 2 1 160 x 19 1 

4 32 x 17 4 

Bus Type 3 0 192 x 19 0 

2 160 x 17 2 

3 96 x 8 3 

The advantage of this method is that it is simple: no sign mapping is required and a particular 

size sign will always have the same switch setting. 

2 An alternative is to have the sign switch setting denote the position on the bus. Therefore the 

front sign is always switch setting 0, side sign 1 and rear sign 2. In this case, three profiles are 

needed to redirect information to the correct sign on each of the three types of vehicle in the 

fleet. 

Profile 1: 

 

Note: in this profile, apart from sign 5 being redirected to switch 0, all other signs are set to 

disabled ('-'). This will ensure that the information for the other signs will not be sent out, as this 

would slow down communications between the controller and the signs and also cause status 

errors. Accordingly, it is advised not to use the default setting ('*'). 
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Option Description 

 Profile 2: 

 

Again, all signs that are not fitted have been disabled. 

Profile 3: 

 

All signs not fitted have been disabled. Also in profile 3, 'Switch 0' setting could have been left 

at the default setting (*), as it is a one-to-one mapping but it is recommended for clarity that the 

explicit number is used. It is also future-proof because if it is decided later to use container files 

(refer to Appendix C: Container Files) the results are unpredictable when a sign is left on the 

default setting. 
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Option Description 

  

 Sign Switch Setting Sign HELEN Sign Setting 

Bus Type 1 0 32 x 16 5 

Bus Type 2 0 160 x 19 1 

2 32 x 17 4 

Bus Type 3 0 192 x 19 0 

1 96 x 8 3 

2 160 x 17 2 

Although option 2 seems more complicated, it saves time and problems as it will only broadcast 

information to existing signs, thereby avoiding slower communications and status errors. 

Important note: Both options 1 and 2 will slightly increase the size of the database - and in 

some cases may cause a problem by exceeding the memory size of the controller. 

7.2.1.9 Timed Info 

This feature will allow up to 8 information messages to be displayed for a particular time and/or date. 

It is an enhancement to the existing method of enabling an information message to be set for a particular 

date, which had to be implemented via the extensions box (date only). 

 

In the above example, there are three information messages set: 

• The first message will display between the last day of the year to the first day of the next year 

(inclusive). 
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• Message 2 will display everyday between 10 in the morning to 2 in the afternoon. 

• The last message will display only on the 1st of June between 4 in the afternoon to 7 in the evening. 

It can be seen that the first two messages overlap. In this case, message 1 will display until 10 when 

message 2 will display until 2 in the afternoon, then it will revert to information message 1.  

7.2.2 Console edit 

 

This allows the configuration parameter string to be edited directly. 

 

 

 

 

 

 

 

7.2.3 Fonts submenu 

7.2.3.1 The Font editor6 

Fonts are a fundamental requirement for HELEN to function fully and HELEN can store a range of different 

font libraries. Hanover’s Roman-character font library is Eurofont but others are available to cater for Arabic, 

Chinese, Greek and Cyrillic character sets, for example. Users can also import their own font library. This 

section is based on using the Eurofont character set (library). 

 
6 Fonts are located in font library files in the format fontlibraryfilename.fdb and stored in the following location: 

• XP: Documents and Settings\All Users\Application Data\Hanover Displays\HELEN 

• Win 7, 8 or 10: Program Data\Hanover Displays\HELEN (which may be hidden) 

Note: as no checking is done, the string may not adhere to the required format, or the parameter 

names and values may be incorrect. The controller ignores anything that is not correct, so it 

may not behave as intended. This may cause loss of functionality: only use if additional 

parameters are required. Using the Extensions feature is recommended if additional 

parameters are required (see section 7.2.1.2 Advanced). 
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HELEN has a font editor, with many useful functions for manipulating whole fonts and individual characters 

within a font. The font editor can be accessed from the Destination List screen by selecting Options → Fonts.  

The image below shows the font editor screen for a standard font: 

 

To select particular font to view or edit, click on it from the list situated at the top of the screen e.g. 0505C1E1. 

To view a specific character in the font, click its button in the character button grid. Alternatively, press the 

character’s keyboard key, scrolling through the fonts using the left / right or up / down arrow keys, or type 

in the Windows decimal value of the character in the ‘Char Code’ box.  

Note: every character is assigned a unique character code.  
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Alternatively, the image below shows the font editor screen for a Unicode font: 

 

7.2.3.2 Character functions 

 

The Char menu contains the following functions; all have associated shortcut keys linked to them.   
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For example, to invert a character, press Ctrl+I. Relevant keys are shown in brackets (remember the Ctrl 

key): 

• Copy (C) and Paste (V) take the current character to and from a clipboard area7 

• Mirror (M) rotates the current character about the central vertical axis 

• Invert (I) rotates the character about the central horizontal axis 

• Shift Up (U) and Shift Down (D) move the character in the specified direction by one row 

• Shift Left (L) and Shift Right (R) move the character in the specified direction by one column 

7.2.3.3 Mouse operations 

• Clicking the left mouse button on a dot turns it yellow 

• Clicking the right mouse button turns a dot black 

• In both cases, to change several dots, hold down the mouse button and drag it over them 

• Shift + left mouse button on the row inserts a row above 

• Shift + right mouse button deletes that row 

• Ctrl + left mouse button moves the character up one row. 

Note: yellow dots disappearing off the top of the screen are erased so will appear black if the 

opposite action is then taken.  

• Ctrl + right mouse button moves the character down one row. 

Note: yellow dots disappearing off the bottom of the screen are not erased so will appear yellow if 

the opposite action is then taken.  

• Alt + left mouse button anywhere in the character body deletes the column at that point and moves the 

rest of the character to the right one column to the left. 

• Alt + right mouse button anywhere in the character body inserts a blank column at that point and moves 

the rest of the character to the right one column to the right. 

Alt + left mouse button in the column space therefore reverses the above action. To move a character 

to the right, insert a blank column at the far left of the character matrix.  

Note: when using the alt key, yellow dots are erased (turned black) if they are sent off the screen to 

the left or right.  

7.2.3.4 Creating fonts 

 

 
7 Note: this is not the standard Windows clipboard. 
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To create a new font, click File → New Font and the ‘New Font Information’ window will appear as shown 

below: 

 

Parameter Description 

Font Name  

(9 chars) 

Enter a font name (e.g.1612N2E1) using the convention given in 4.3.3 Selecting 

fonts for the sign. This nomenclature is useful as it describes the characteristics 

of the font – however, any name can be used (no more than nine characters long). 

Height /  

Width /  

Space /  

Inter Char Space 

Adjust the height, width, space and inter-character space using their respective 

up / down arrow buttons.  

The width parameter defines the maximum width allowed for any character of 

that font: it does not mean that every character has the same width.  

Space refers to the width of the space character of the font in dots. 

Inter Char Space relates to the number of dots between characters in a string. 

Adjustment decisions should be based on the size of the font required for use. 

The height value is chosen according to the sign size e.g. a 19 LED-high sign 

could be used for showing two lines, each 9 LEDs high (with a row of dots as 

a line space in between) so the height should be set to 9 in this case. The width 

can then be estimated – select a value that will accommodate it: if it is slightly 

larger, it will still fit; too small and it will not.  

Note: this process will need to be repeated (along with any editing) for each font 

size chosen (different sign sizes are likely to need different font sizes). 

Single Byte / Double 

Byte / Unicode 

Select either ‘Single Byte’ or ‘Double Byte’.  

Single Byte refers to a font set comprising a maximum of 256 characters; it is 

recommended to select this option.  

Double Byte is used for fonts that can contain over 65,000 characters. They 

are used for Chinese and other Far Eastern fonts.  

Unicode is the current computing industry standard for handling most of the 

world’s writing systems. 
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Parameter Description 

Cancel /  

OK 

Another and probably easier way of creating a new font is to base it on one that 

already exists. To do this, first select the font the new font will be based on. Then 

select File → Save As and enter a unique font name and click OK (Cancel aborts 

the operation). Once a valid name has been entered, this new font will be exactly 

the same as the one from which it has been copied: it can then be edited in the 

manner described above.  

7.2.3.5 Previewing fonts 

 

Font → Preview displays the currently-selected font library.  

 

Click on ‘Exit’ in the top left corner to return to the font editor. Alternatively, double-click on a character to 

show that character. 
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7.2.3.6 Comparing fonts 

 

Font → Multiple Font Editor enables the viewing and editing of characters from any number of fonts.  

The following figure shows the Multiple Font window with four selected fonts from the list box: 

 

Drag the mouse over the font names to select consecutive fonts. Hold the control key and click to select 

individual fonts.  
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To view a specific character in all of the selected fonts, press the character on the keyboard. Extra fonts 

can be shown by using the control key and selecting them from the font list. If the character is not available 

on the keyboard, hold down the Alt key and type in the relevant decimal code (e.g. <alt>+155 will show the 

fonts’ representation of the ‘¢’ character). 

The ‘mini-fonts’ can be edited directly. To do so, click the left or right mouse button to change a dot to yellow 

or black respectively or hold the button down and drag the mouse over the desired area. The window can 

also be resized to allow for more fonts to be viewed at one time. 

7.2.3.7 Importing fonts 

 

a) Importing Hanover fonts 

From within Font Editor, select Font → Import → Hanover Fonts. Locate the Hanover font to be imported 

and click OK. This feature is used when a more up-to-date version of a standard Hanover font is required 

(e.g. containing additional characters) or where an additional font is needed. Contact Hanover in these 

instances. In the case where an updated font is being imported, the details of any user-created characters 

should be saved elsewhere as these will, of course, not be part of the standard Hanover font in question 

and will have to be recreated. 

b) Importing Windows fonts 

This feature can be used to extend an existing Hanover font or to create a completely new one. When using 

Windows ‘True Type’ fonts in the Sign Designer screen, HELEN will automatically resize the characters 

when the text is ‘dropped’ in order to provide the best fit. If required, characters must be altered individually 

every time this is done. By importing a Windows font into the Hanover font library, the alterations need only 

be done once and, in this way, a complete customised ‘Windows-style’ font can be created by the user.  

To extend an existing font, first select it from 7.2.3.1 The Font editor or, if creating a new one, go through 

the procedure at 7.2.3.4 Creating fonts and again select the font from the list. 

From within Font Editor, select Font → Import → Windows Font.  The Font Importer window will appear as 

shown below. 

Click Change Font and select the Windows font to be installed, along with its style.  Choose a smaller size 

at this stage: the final size can be adjusted later.  Individual characters can be viewed by clicking on the 

scroll bar slider (it will then start flashing) and entering the chosen character. 
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The height in dots of the font must be checked to make sure it fits into the space available ('Adjust Font 

Size').  As the font size increases, the font position will need to be adjusted vertically.  Windows fonts do not 

generally display satisfactorily on the smaller height signs: sizes of 16 LEDs or higher are the most 

appropriate.   

Tip: start with an upper case 'W' as this is generally the widest character. 

Note: it is important to ensure that all 

characters will fit: for example, it is a good idea 

to check that the descenders of characters 'g', 

'j', 'p' & 'q' (the lower parts), the ascenders (top 

parts of certain characters) and accents on 

accented characters are all shown 

satisfactorily. 

Once the necessary checks and 

adjustments have been made, click Save 

and the following Import Options dialogue 

box will appear.   

A single character, a range or the complete 

character set can be imported.  Click OK to 

convert it to a HELEN format. 

A confirmation window as shown below will appear – check the details and if correct, select OK. This font is 

now editable in the Font Editor.  

 

By default, the whole font is imported but if only certain characters (or a range of characters) were included, 

additional characters can be added to the font later by repeating the process. 

Ticking the 'Blank entries only' checkbox will ensure that any existing characters within the HELEN font will 

not be overwritten when importing a range of characters which may overlap with them.  (This function is 

based on character codes, i.e. regardless of how the character might have been edited, a 'new' character 

045 will not replace an existing 045: it will simply not be imported.)  
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c) Smoothing 

In most digital representation of letters, numbers and symbols, the character edges are not perfectly smooth 

but are 'treated' to look as though they are when viewed at the intended size.  These characters are 

comprised of dots, pixels, small squares etc.  An example of this can be seen in the following figure where 

the edges have additional shading and colours applied.           

 

                                                                       

 

 

A similar approach is taken in HELEN with the smoothing feature, where some characters represented are 

not just drawn only in black and white but (in the coding) use grey dots to make the curves of the character 

look more realistic. 

These images are not viewable by the user. By default, the Windows font importer switches off this 

'smoothing' (it is restored to its original 

setting when closing the font importer) but 

it may be switched back on. 

When 'Smoothing' is selected, an extra 

panel becomes visible in the 'Importing 

Characters' dialogue box. The 'Contrast' 

scroll bar will determine the point at which 

the grey dots are recognised. 

Smoothing may, under certain 

circumstances, give a better character 

representation.  However, as with 

Windows True Type fonts, it is only 

advisable to use this technique on large-

sized signs as the result can be 

undesirable on smaller sizes. 
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d) Exporting HELEN fonts 

 

Having selected a font, select Font → Export from within Font Editor.  In the Export Font dialogue box, 

specify the file location where the font is to be saved. 

There is an option for exporting the selected font or exporting all the fonts from within the library. 

This feature is useful if new fonts have been created and HELEN is to be re-installed (e.g., where an updated 

version is to be used).  HELEN will not, of course, have any user-added fonts as standard so exporting and 

saving them prior to re-installation will allow them to be added back in (refer to 7.2.3.7 Importing fonts). 

7.2.3.8 Creating new characters 

a) Creating new symbol characters 

New symbol characters can be added to any of the LOGO fonts directly from within Font Editor.  

Open Font editor from the Options tab in the main window and select one of the LOGO fonts from the font 

box.  Select a currently unused character from the grid - say, P - this will appear in the character code box.  

font box 

 char code box 

 

selecting the 
character ‘P’ 
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A new symbol can then be created simply by 'drawing' on the blank matrix on the left: left-clicking the mouse 

generates a yellow circle whilst right-clicking changes it back to black.   

Alternatively, a new symbol can be based on one already existing.  As before, open Font editor from the 

Options tab in the main window and select one of the LOGO fonts from the font box.  Select the desired 

symbol so that it appears in the matrix and click Char → Copy.  This copies the symbol to the clipboard.  

Find an unused character in the grid and click on it (ensure this delivers a blank matrix) then click Char → 

Paste: the chosen symbol appears on the matrix and is allocated the corresponding alphanumeric or symbol 

character.  The new character can then be edited as required. 

Whichever method has been deployed, when drawing / editing the symbol has been completed as required, 

click File → Save and the new symbol will be added to the relevant font set under the chosen grid character. 

b) Creating other characters 

The process described in a) Creating new symbol characters above can be applied to any character set, 

using spare character buttons in the grid (though the user will need to remember which button has been 

used as they cannot be marked). 

Open Font editor from the Options tab in the main window and select the desired font from the font box.  

Create and save the new character as described above.  Alternatively, select the relevant character so that 

it appears in the matrix and click Char → Copy.  (Note: this source character can be copied from a 

completely different font or font library if required.) 

7.2.3.9 Other functions 

• The Font menu 

 

Menu item Description 

Parameters Select Font → Parameters to switch the font between a single and double-byte 

font and also to adjust the character height, width of the space character and the 

inter-character space. 

Remove Select ‘Remove’ to delete the currently selected font. 
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• The File menu 

 

Menu item Description 

Save Saves all changes made to the current font.  

Save As… Saves the current font as a new (identical) font usually for editing. 

Print Setup Allows print options to be set. 

Print Prints the currently selected fonts. 

Note: no print dialogue window opens (options must first be set using ‘Print Setup’). 

7.2.4 Advert submenu 

 

7.2.4.1 Editing advert.txt 

All the text for the adverts must be contained within a file called 'advert.txt' which must be located in the 

same directory as other HELEN data files, e.g. for destination messages.  To edit this file, the relevant 

destination list database will need to be loaded.  In the Destination List window, select Options → Advert. 
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The following LED – Advert converter window will be displayed: 

 

Parameter Description 

LED Sign Type Leave the database type to Upper + Lower. 

LED Sign Addr. The 'LED Sign Addr.' setting is only used if embedded graphics are required.   

Edit To change the adverts, click Edit to be taken into the standard Windows notepad 

editor, where the advert messages can be altered. 

Review If an LED sign is connected to a serial port on the computer, the messages can be 

seen on the sign by double-clicking one of the entries in the review list.  To do this, 

an RS232 / RS485 adaptor and appropriate cable will be needed to drive it directly 

from the computer's serial port. 

7.2.4.2 Advert text and control sequences 

Except for accented characters, any upper or lower case character up to 'z' can be used in an advert 

message.  In addition to the actual text characters, it is possible to use special control sequences which 

alter the appearance of the message as it is shown on the LED sign. 

7.2.4.3 Sign control sequences 

Each sequence is of the form: \x where 'x' is a single lower case letter.  Each sequence should start at the 

beginning of a line. 

The sequences are the same as those used in the standard Hanover in-bus LED sign software.  
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The various control sequence letters and their functions are listed below: 

• General sequence control characters 

Character Description 

\b blanks sign for one second after a static message; multiples can be used to increase 

blank display time 

\d clears display as soon as last character of present text enters display 

\e scrolls text until current text leaves display 

\f toggle causes text to flash 

\g…g embed graphic from HELEN information message 

\gXX.PPg where XX is the info number 1-99 and PP is the page number 1-16, e.g. \g1.2g will 

embed the graphic for info 1, page 2 (from the current LED sign addr. setting) 

\l scrolls static text down to clear display 

\n set normal font 

\p short pause - pauses display for 1 second after a static message; multiples can be 

used to increase display time 

\P long pause - pauses display for 2 seconds after a static message; multiples can be 

used to increase display time8 

\r spells out text in a static sign (letter by letter) 

\s shows static message (limited to 14 characters) 

\u scrolls static text up to clear display 

\w set wide (bold) font 

• General sequence control characters 

Character Description 

\\ Is converted to a literal ‘\’ 

• File control 

Character Description 

\# comment - anything following on this line is ignored 

\* end of message (good practice is to place this on its own line) 

 

 
8 Control characters are not case-sensitive: if 'P' is required, a setting needs to be changed in Helen.ini 
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Note: 

Each of the above control sequences must be on the same line as the text which it controls.  The text itself 

must not be split across two lines.  Additionally, any trailing '\' will be treated as a literal '\'. 

With the rules above, blank lines, new lines and comments can be used to make the source text file more 

understandable. 

For in-bus LED software, the message body text can contain any ASCII character in the range '(space)' to 'z' 

inclusive and the control sequences are sent as '\x' (i.e. with the '\' character - see above). 

When using these control sequences it can sometimes be difficult to imagine exactly how the display will appear 

so it is worth viewing new text on an actual display before loading the new definition into all the sign systems. 

Example: 

\# This is a comment and this line is ignored 

Here is an Advert \sThis is static \p\p\d and here is some more scrolling text 

\*  

\fThis is the 2nd advert\f \wThis bit is in wide\n 

\* 

This is the 3rd advert  

 

Once the list is complete, it must be converted to binary.  This is achieved by clicking Review which also allows 

the list to be previewed. 

7.2.5 Configuration submenu 

 

In the Destination List window, select Options → Configuration.  
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The following Configuration window will be displayed: 

 

Prior to HELEN version 2.0o, most of these options had to be set in the helen.ini file.  

Parameter Description 

Font Options9 The dropdown box enables the selection of alternative font libraries. The default is 

EUROFONT.  

Drivers Message The default is to have upper case only. Some older controllers were unable to have 

drivers’ messages with lower case characters.  

Send Port Send Port defines the port on the user’s PC which will be deployed by HELEN when 

linking with other devices such as loading a dataloader (this may be when a controller 

is used as a dataloader). 

The dropdown list enables the user to select the 

correct port as determined by the PC. Ports 1 

to 16 are available although this value can be 

manually edited (in helen.ini) for values above 

16. 

Note: this value is also used when driving a 

sign directly from the computer for test 

purposes (via the ‘Messages’ option in ‘Preview’). 

 
9 The font files are located in font library files (.fdb) stored in the following location: 

• XP: Documents and Settings\All Users\Application Data\Hanover Displays\HELEN 

• Win 7, Win 8, Win 8.1 or Win 10: Program Data\Hanover Displays\HELEN (which may be hidden) 
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Parameter Description 

Email Details This is a feature whereby the working database list can be compressed and the Zip 

file can be sent to Hanover Displays for inspection. The button will enable the inclusion 

of the user’s name, company and telephone number, which will be added to the file to 

enable Hanover to assist the customer more easily.  

Helen.ini This feature allows direct access to Helen.ini where various options can be set. This 

file is no longer installed in the application folder and its location is operating system-

dependent. HELEN may have to be restarted depending on which parameters have 

been modified.  

For more details, please refer to Appendix B: HELEN initialisation file (helen.ini). 

Output File 

Creation 

 

 

 

 

 

 

 

Feature Description 

Standard By default, HELEN will create the standard ‘Eric.bin’ file for 

sending to a dataloader or Key-lo. 

Radio Transfer File 

(WHF) 

A special compressed ‘Eric.whf’ file is created for transferring 

via a radio link or wifi. 

Container Selecting ‘Container’ will enable ‘Configuration’. Refer to 

Appendix C: Container Files. 
 

Compression There are cases where the database is too big into the controller even when using 

container files. It may be possible to improve the situation by compressing the Eric.bin 

file10 (the default is to have no compression). Compression level 1 provides quick 

compression, whereas level 2 will take much longer to process although will give 

slightly better compression than level 1.  

However, this should only be regarded as a temporary solution as the extra capacity 

offered by level 2 is minimal; the feature is best used as a warning that the size of the 

database is too large and must be reduced. Methods for doing this, including the use 

of profiles, are covered later in this manual.  

Note: all current Deric+, Eric++, DG3 and EG3 controllers can handle compressed 

files although very old models may need a firmware upgrade for which Hanover must 

be contacted. 

Therefore, use level 2 only if level 1 has failed to produce a loadable database. The 

amount of compression achieved will depend mainly on the type of data being 

compressed. For example, graphic data will compress well but text messages 

(including Super-X) will not be compressed.  

Level 3 compression (gZip) has been optimised to work with full colour signs.  

 
 
 
 
 
 
 
 
 

 
10 Note: This technique is different from the compressed file used for radio transfer (Eric.whf). 
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Parameter Description 

RN Info Paste When this box is ticked, the image in the route number (RN) field is copied into an 

7.5.2 Information page, thus keeping the route number visible while the information 

page is being shown. 

In addition, the character ‘%’ should be placed into the route number field of each 

information message that is displayed with the current route number. Refer to 

Appendix L: Programmable route numbers and Appendix Q: Pasting a Route number 

into an Information page. This reserves a fixed amount of empty space where the 

route number will be displayed. The amount of space reserved is the space configured 

for the route number field in the HELEN sign configuration window.  

Super-X Options The Asymmetric Two-Line Super-X option is specifically to create a larger top 

destination field which will ensure that externally-viewed signs meet UK disability 

discrimination legislation when using two lines on certain height signs.  

Note: A more elegant solution can be achieved by increasing the height of the 

destination field by a single row for 17 and 19 high signs. 

7.3 Route menu 

 

Menu item Brief description Refer to section 

Copy Make a copy of an existing destination (or route) 

code. Useful if the new code is to be similar to an 

existing one. 

- 

Insert Code Used when inserting a new code within a list. If the 

code number at the insertion point already exists, 

it (and subsequent codes) will be incremented by 

one until there is a gap. The new code should then 

be given the number pertaining to the space thus 

generated at the insertion point.  

- 

Delete Code Same function as the main ‘Delete’ button on the 

initial window. 

Note: ‘Delete Code’ is not the opposite of Insert 

Code. ‘Delete Code’ will not decrement – it just 

deletes, renumbering the remaining codes.  

5.4 Deleting an existing destination 

 

Find Quick way to find an existing destination in a long 

list.  

5.3 Editing an existing destination 
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7.4 Help menu 

 

Menu item Brief description 

About Helen… 

 

Gives details of the HELEN version number and contact details. It will also show the 

version number of all the files used by HELEN. This can be useful for diagnosing 

particular problems. This pop-up also contains the Support button to automatically 

compress all the files in the working list to make it easier to send to Hanover for 

inspection.  

7.5 Destination / Information / AVL radio buttons 

7.5.1 Destination 

 

This will show the destination codes (numbers) and the driver’s message. If there are trailing dots following 

the driver’s message, this indicates that there is more than one page. Any item in the list can be edited by 

double-clicking. 

  

The default 
is 
‘Destination’. 
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7.5.2 Information 

 

Information messages are a useful way of showing information which is not route-specific such as ‘Happy 

New Year’. An information message is presented as an additional page after a standard destination message.  

7.5.3 AVL 

 

If an AVL database is being deployed, this will show the preambles, stop messages and triggers.  

7.5.3.1 Overview 

Hanover’s Automatic Vehicle Location (AVL) system is designed for in-bus LED signs only.  It formerly used 

the AVL edit system in HELEN but this has been superseded by Hanover's ASE software.  The ASE program 

will create an ase.bin file which can then be integrated into the load file (eric.bin). However, the ASE software 

has been primarily designed for western languages and not complex scripts such as Arabic or Chinese.  

These scripts cannot be represented by simple text and therefore a graphical system needs to be used. 

 

7.5.3.2 Destination list 

The destination list window in HELEN is the starting point for most HELEN activities.  This window can show 

three different lists; a destination list (entries beginning with 0s) an Information list and an AVL list for in-bus 

LED sign messages.  The latter comprises two types of message: 

• Preambles (entries beginning with PR) 

• Stop-name messages (beginning with ST) 

  

Please note that if using an AVL system driven by a sign controller, it must be an Eric model 
with AVL firmware installed.  Please consult Hanover who will be able to advise. 
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The figure below shows a typical AVL list: 

 

To create a new item, select the AVL radio button and click New.  

There is now an option to create a Stop, Preamble or Other (user-defined) file (the ST or PR prefix will be 

added automatically). 

 

7.5.3.3 Editing LED messages for AVL 

When editing a message, only message data for an in-bus LED sign that has been configured by HELEN 

should be entered (in the example below, sign 5). Each message page can have either  

• graphic data (use the  button) for Arabic or Chinese characters or special symbols 

• or text data (use the  button) for Latin characters – though this option should not be necessary 

as non-graphic data can be created in the ASE program. 
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7.6 Edit / New / Delete / Preview buttons 

 

 

7.6.1 Edit 

Select an item on the list and click Edit to edit it. This has the same effect as double-clicking the highlighted 

list item.  

  

7.6.1 Edit 

7.6.4 Preview 

7.6.2 New 

7.6.3 Delete 
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Depending on whether Destination, Information or AVL has been selected, the following window will be 

displayed: 

• Destination 

 

The destination code and driver’s message can be changed from this window or Edit Signs can be clicked to 

edit the sign.  

• Information 

 

• AVL 

 

7.6.2 New 

The New button enables the creation of a new destination (or information message or AVL message). For 

more information, please refer to 5.1 Creating new destinations. 

7.6.3 Delete 

The Delete button deletes the item highlighted on the list. 
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7.6.4 Preview 

The Preview button reveals how the destination (or Information / AVL message) will be shown on the signs. 

 

As described previously, the preview screen shows, dot for dot, the image that will be created on the signs 

when the corresponding destination code is entered on the driver’s controller. It will also show the driver’s 

message (text only). The driver’s message preview will use the configuration parameters to show either one 

or two lines and to determine whether to convert to uppercase or leave in mixed case.  

If any amendment is required, double-click on the sign to be taken to the Sign Designer (refer to 8 Sign 

Designer). Also, double-clicking the driver’s message leads to either the ‘Edit Route Code and Name’ or ‘Edit 

Info Id and Message’ pictures in 7.6.1 Edit depending on whether Destination or Information is being shown.  

The next or previous destination can be previewed by clicking the left or right arrows: . 

If there are multiple pages, the preview screen will change pages at an interval determined by the timer. The 

interval can be adjusted by the slider bar: . 

The default is three seconds. Moving the slider to the left will speed up the paging but the leftmost position 

will freeze the sign for easy inspection. 

The Messages box  is useful for driving a sign directly from HELEN (normally where it is not 

installed in a vehicle). For a standard sign, an RS48511 adaptor and an appropriate cable will be needed to 

drive it directly from the computer’s serial port.  

 
11 This and other communication connections are available from Hanover.  
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8. Sign Designer 

8.1 Introduction 

There are two ways to access the Sign Designer screen from the Destination List window. Highlight the 

destination sign to be edited, then 

1. Either click Edit (or double-click the highlighted sign). When the Edit Route Code and Name window 

appears, click Edit Signs. 

2. Or click Preview and double-click on one of the sign images. The sign designer will be loaded with 

the first page of the sign that has been double-clicked.  

The following Sign Designer screen will be displayed:  

 

 

 

 

8.2 Sign Designer – Opening Screen Functions 

8.2.1 File menu 

 

Menu item Brief description 

Save (or Ctrl+S) Saves all sign images within the current destination code.  

Exit (or Ctrl+Q) Asks whether any changes made should be saved and then returns the user to the 

previous screen. 

8.3.1 Text Input Options  

 

8.3.2 Font Selection 

8.3.5 Special  

 

8.3.3 Save & Exit 

 

8.3.4 Sign 0 / Page  

 

8.3.6 Draw / Edit 

 

8.3.7 Super-X 
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8.2.2 Edit menu 

 

Menu item Brief description 

Copy Sign /  

Paste Sign /  

Undo Sign 

This function allows the copying and pasting of complete sign images. By 

selecting Edit → Copy Sign, the sign image and the text in the text boxes will be 

copied to a clipboard area and Edit → Paste Sign will then paste this information, 

either to a different sign or another page of the same sign. 

In this case, as there is no specific area to move (nothing has been selected) the 

whole sign is pasted with the top left-hand corner of the original sign aligned to 

the top left-hand corner of the new one.  

Note: a difference in the sign size will not affect the ‘Paste Sign’ function: it will 

be pasted dot-for-dot.  

For this specific function, Edit → Undo Sign allows the ‘Paste Sign’ action to be 

undone, restoring the original image.  

Note: this ‘Copy Sign’ function copies an image to a separate clipboard from the 

standard Windows ‘Cut’ and ‘Copy’ clipboard.  

Insert Page/ 

Remove Page 

This feature allows the easy insertion or deletion of a page.  

Note: useful particularly for colour signs.  
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Menu item Brief description 

Bitmaps Import 

Export 

This feature is the use of the bitmap format. It is possible to create and import bitmap 

images of signs, which can be edited by (exporting to and using) a bitmap editor 

such as Paint. When creating a sign as a bitmap, it is important that the height and 

width attributes in pixels of the entire bitmap match those of the sign in dots. This is 

because each dot must be represented by one pixel in the bitmap image. It is also 

important that the bitmap image is made in black and white. To see what a sign looks 

like as a bitmap, export a sign image and view it in a bitmap editor.  

Here is an example: 

This is the sign represented in HELEN. 

 

Selecting Edit → Bitmaps → Export Bitmap Image will give a standard Windows 

‘Save as’ dialogue box. Save the file in .bmp format and open it in Paint. 

It will look like this: 

 

Editing can then take place and the file re-imported to HELEN using Edit → Bitmaps 

→ Import Bitmap Image. Newer versions of Paint have gridlines available in ‘View’. 

Using this principle, individual pixel-type images can be added to any of the LOGO 

fonts by importing any (monochrome) bitmap image. It must be a maximum of 16H 

x 32W (LOGO) or 14H x 32W (LOGO 16) and can be saved to a ‘spare’ character in 

the chosen font’s character set. Appendix I: Alpha to symbol converter (Hanover 

fonts) shows the pre-installed characters in these two fonts. 

Completely new characters can be added to any of the LOGO fonts from within 

Font Editor – refer to a) in 7.2.3.8 Creating new characters. 

Edit Facility to directly edit the bitmap via ‘Paint’ called from within the program.  A 

menu item will launch ‘Paint’ with an Open File dialogue to select the BMP 

required.  

Remove Feature to delete the bitmap from that page. 
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8.2.3 Select menu 

 

Menu item Brief description 

Next Page / 

Previous Page 

Up to 16 pages 12  of a particular destination can be created for any sign. 

Navigating to the next page up or down can be done by: 

• pressing PgDn  / PgUp  

• or clicking ‘Next Page’ or ‘Previous Page’ from the ‘Select’ menu. 

Next Sign / 

Previous Sign 

To switch between configured signs: 

• press Ctrl + PgDn / PgUp, 

• or click ‘Next Sign’ or ‘Previous Sign’ from the ‘Select’ menu. 

8.2.4 Options menu 

 

Menu item Brief description 

Max Space 

Saving 

This feature can be chosen from the ‘Options’ menu. A tick to the left of ‘Max Space 

Saving’ means that it is turned on. When a sign is first chosen, a certain amount of 

space is automatically allocated for the route number, depending on the sign size (it 

can also be adjusted manually) with the number aligned in the centre of this space. 

However, this can mean that some of the space is wasted. ‘Max Space Saving’ sets 

the route number to the leftmost (or rightmost) column of the sign, thereby freeing 

up space for the remaining text. This option is set automatically when the destination 

is first created (note that older versions of HELEN did not turn this option on by 

default). 

 
 
 
 
 
 
 

 
12 16 is the default which can be changed in helen.ini. 
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Menu item Brief description 

Regeneration 

Lock 

This feature prevents the current page from being altered upon regeneration. This 

is useful if the destination list requires regenerating but graphical edits have been 

made to fit messages on certain individual pages. Selecting ‘Regeneration Lock’ 

from the ‘Options’ menu ensures that no automatic edits can take place on that 

particular page. The regeneration lock will be activated automatically if any 

graphical edits have been made.  

For more information about sign regeneration, please refer to 7.1.4 Regenerate 

submenu. 

Frame Enable FrameEnable is a switch on feature to enable multi-page messages to be sent to a 

sign - first used with full colour signs with enhanced memory. Normally switched off 

as this feature is presently not available in standard signs. 

Frame Duration Amount of time a frame (page) is displayed on the sign.   

Super-X Multipage This will set all the pages for this destination to be treated as one multipage message, 

rather than a series of separate pages. It has the advantage that the sign will now 

handle the timing of the pages and synchronise any scrolling messages.  

Note: This can only be set on the first page – all subsequent pages will be set 

automatically (refer to Appendix P: Working with Multipage Super-X). 

8.3 Functions of Sign Designer features 

8.3.1 Text Input Options – Presenting text as a graphical image 

 

The sign designer has a number of features that allow editing so that it can show any image required – this 

includes the text itself (presented as an image). The main method is to enter text in the text input box and 

‘Drop’ it on the sign mimic below. 

Select the style of sign layout (refer to Appendix R: Layout Configurations), using the up and down arrows 

to the left of the sign text boxes (or Ctrl+Up / Down arrow) then type the text into the boxes. Different layout 

styles can be tried; any text typed into the text boxes will remain there until either Drop and Save & Exit are 

clicked. At that point, only the text in the boxes for the selected layout style is kept.  

Note: dropped text will be overwritten by new dropped text.  

The Preview button shows the text image on the sign mimic in red. The Drop button shows the text in yellow 

for a flip-dot sign, amber for an LED destination sign and green for an in-bus LED sign. Preview images are 

not saved.  

Both the text input box and that on the sign mimic can be edited directly. Once the desired result is achieved 

in the mimic, clicking Save & Exit will save it.  
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If required, edits can be discarded simply: 

• by closing the Sign Designer window if Save & Exit has not been clicked (using the ‘X’ in the top 

right-hand corner) or 

• if no changes have been made to the text input boxes, by clicking the Drop button. 

Note: the drop button only relates to what is in the text box and that pressing Drop (or Enter) after an 

unsaved graphical change will erase the graphics. 

Special characters (i.e. those not directly available on the keyboard) can be inserted in the text box by 

pressing  Alt+code where code is the decimal code for the required character. Many lists of these can be 

found on the internet but one of the most comprehensive is at ‘The World of Stuff’ 

(http://www.theworldofstuff.com/characters/).  

8.3.2 Font Selection 

 

8.3.2.1 Selecting Hanover fonts 

By default, font selection is automatic and the fonts are chosen from the 20 fonts that were picked when the 

sign was selected (refer to figure in 4.3 Sign Parameter Editor). An improved appearance might be achieved 

manually by selecting another font.  

In the font selection section, there is a drop-down font list for each of the sign’s text input boxes. Fonts are 

selected by clicking on the font name and browsing the list by using the up and down arrows. Any font can 

be selected for each of the input boxes – as long as it will fit: selecting a font 16 dots high will produce an 

undesirable result if the sign is only 7 dots high. Fonts shown in red are manually-selected fonts. Check the 

‘auto’ box to return it to an automatic font. Click Drop to reproduce the sign image with the chosen font. This 

will also cause the identity of the ‘auto’ font to be shown. 

If a certain part (or all) of the text is not then represented on the sign, this may be for two reasons: 

• either the message in the text box is too large to be reproduced, 

• or the characters in the message are not represented in the font database. 

Solve the first problem by: 

• either reducing the number of characters in the message (and maybe deploying a second page), 

• or using Max. Space Saving (refer to 8.2.4 Options menu). 

The second problem can be resolved by using the font editor (refer to 7.2.3.1 The Font editor). 

  

http://www.theworldofstuff.com/characters/
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8.3.2.2 Inter-character space 

The asterisk to the left of the selectable fonts is the inter-character space selector. 

              

 

The figure on the left shows the default inter-character space of 2 dots for this font (1912B3E1) where ‘*’ is 

the default. The space between the characters can be increased (by up to 10) or decreased (down to 1) by 

using the left / right arrow keys.  

The figure on the right shows the result of increasing the value to 4.  

Note: the space between characters cannot be altered using this method if they are in a Windows font. 

However, if this case, the required adjustment can be made using the selection function, once the text is in 

place. Please refer to 8.3.6 Draw / Edit. 

8.3.2.3 Selecting Windows fonts 

From HELEN version 2.0o, there is an additional method of font selection. Rather than using individual 

characters stored in a font database, this method uses the Windows fonts on the computer. It uses a scanned 

graphical method which works best on larger-sized signs. For smaller signs, the previously-described 

Hanover font system will give better results.  

Here is an example: 

 

Tick the TT font selection box for the required field (in this example, the destination field – colour-coded green) 

and then click Drop. 

TT font 
selection box  
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The following window will be displayed: 

 

The destination field has turned turquoise. The sign is in a different font and the font selection box has 

changed. Clicking Font will activate the following font dialogue box which will show that the default selected 

font is Arial.  
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For this example, try selecting another font – say, Times New Roman. Click OK and then Drop. The 

destination is now shown in that font.  

Note: once a particular Windows font has been chosen, HELEN will remember it the next time a Windows 

font is used.  

 

The largest size of font will be automatically selected to fit the available space. A manual adjustment to the 

font size can be made using the up / down arrows to the right of the Font button. 

8.3.3 Save & Exit 

 

Save & Exit saves the current destination messages for each sign and returns the user to the previous screen. 

8.3.4 Sign 0 / Page 

 

To switch between configured signs, click the up / down arrows next to the sign box. 

Up to 16 pages13 of a particular destination can be created for any sign. Navigating to the next page up or 

down can be done by clicking the up / down arrows next to the page number box. 

  

 
13 16 is the default which can be changed in helen.ini. 
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8.3.5 Special 

 

8.3.5.1 Invert button 

Invert turns black dots amber (or yellow or green) and vice versa for the whole sign. This may be required if a 
bitmap image is imported with a black image on a yellow background – or simply for effect.  

Note: moving text and numbers using the selection button will not work on inverted text; text should be moved 

first and then inverted.  

8.3.5.2 Blank button 

Pressing Blank turns all dots black for the current sign. 

8.3.5.3 RN Colour 

 

Hanover produces two types of colour signs: 

• a   monochrome sign with the route number in colour (colour route number-only signs are a subset 

of these) 

• a sign with all the information in colour 

A route number can be given emphasis by the use of colour. The Hanover system has an initial palette of 64 

colours which allow a choice of coloured foreground and background plus an optional stripe and character 

outlining option. A colour route number can be included in a destination sign or deployed as a separate route 

number sign. 

  

When a monochrome sign with a colour route number 
has been selected, the ‘RN Colour’ button becomes 
active and a thin white line is used to separate the 
colour and monochrome sections of the sign. By 
default, the colour section will mimic the monochrome 
section. 
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a) Selecting a route number sign 

Coloured signs are selected from the dropdown box of the Sign Parameter Editor window (refer to 4.3 Sign 

Parameter Editor). 

The following figure shows a 128 x 15 

monochrome sign with a colour route number 

selected (Colour RN): 

 

The width field of the route number is fixed as it 

relates specifically to the chosen sign. If two rows 

of information are to be shown, there are options 

available for varying the height of the rows, subject 

to the sign’s overall dot height. Obviously the left 

and right justification can only work with the colour 

panel in the appropriate position. The justification 

must be specified when ordering the sign from 

Hanover. 

 

 

To select a particular colour, click the ‘RN Colour’ button and the colour selection window will appear as 

shown: 

 

 

 

 

 

 

 

 

 

 

b) Standard Colours 

The colour selector will draw a number of different ways to select a particular colour. The simplest method is 

to pick from one of the 64 standard colours. Using the mouse to hover over a colour will show the specific 

combination of red, green and blue hues used to create that colour. 
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c) Custom Colours 

To generate additional colours, either double-click one of the custom colour boxes (or click on one of the 

custom colour boxes and click Select) and then choose from the colour options available. 

       

The Custom Colours form gives three methods of selecting a colour:  

Tab Description 

Hexagon The colour hexagon gives a standard method of choosing from 127 colours plus a 

grey scale.  

Note: beneath the palette, the upper box shows the new (selected) colour and the 

lower box the original colour.  

Sliders Sliders will combine 256 values of red, green and blue which give a total combination 

of over 16 million colours. 

Pantone The Pantone method gives an approximation to a given Pantone number. 

The result can now be previewed as follows: 
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d) Stripe feature 

The stripe feature can be used to give extra information about a particular route. At present, there are 15 

stripe styles. The stripe colour shown below is red but can be any of the available colours.  

 

stripe type 0 stripe type 1 stripe type 2 stripe type 3 

 

stripe type 4 stripe type 5 stripe type 6 stripe type 7 

 

stripe type 8 stripe type 9 stripe type 10 stripe type 11 

 

stripe type 12                    stripe type 13             stripe type 14                  stripe type 15 

e) Outline feature 

The outline feature can be used to improve the readability of the colour signs. 

For example: 
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The above figures show the mimicked representation of a colour route number with and without outlining. 

The outline can be done with any of the available colours but tends to work best with either black or white. 

The method of outlining is done by surrounding an existing character with the outline colour. However, this 

can cause a problem with the inter-character spacing.  

 

 

 

 

The above left figure shows the standard (for this font) inter-character space of 2 between each character. 

As it can be seen, the outline around each character takes up to two-dot space at the bottom causing the 

numbers to merge. This gives an undesirable result. 

By adjusting the inter-character space from the default value of 2 to 4 (refer to 8.3.2.2 Inter-character space), 

the extra two dots are re-introduced and the characters are now separate (refer to above right figure). 

8.3.5.4 Palette (Full Colour) 

 

 

 

A sign with all the information in colour is an extension of a monochrome sign with a colour route number. 

Almost all the characteristics of the colour route number sign apply to the full colour sign. 

‘RN Colour’ button has 
been renamed 
‘Palette’ whilst the 
default colour is set to 
mimic the colour of the 
standard monochrome 
LED sign. 
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Full colour signs are selected in the same way 

as other signs using the Sign Parameter 

Editor (refer to 4.3 Sign Parameter Editor). 

This figure shows the selection of a 144 x 19 

full colour sign. 

 

 

 

 

 
 

 

 

 

Note: RN Colour has been 

renamed Palette whilst the 

default colour is set to mimic 

the colour of the standard 

monochrome LED sign. 
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When Palette is clicked, a palette of four 

possible colours for each individual sign page 

is displayed. Each of the four colours is chosen 

in the same way as for the colour route 

number.  

 

 

 

 

 

 

 

 

This figure shows the result of choosing four 

colours: these now comprise the palette which 

will be used for applying colour to the sign. 
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This figure shows how the 

Sign Designer is displayed 

after two colours are 

applied from the new 

palette. 

 
 
 
 
 
 

 

Double-click a particular text input field to set 

the properties.  

This figure shows the options for the 

‘Destination’ text field (Field 2). 

 
 
 
 
 
 
 
 
 
 
 

The colours for the foreground, background, 

stripe and outline can now be modified. A 

sample of the colourway is shown in the field 

properties panel.  
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This figure shows the 

result. 

 
 
 
 
 
 
 
 
 

The drawing tools can be applied using the left and right hand mouse buttons to determine the colours. In 

the above example, a red line would be drawn by holding down the left mouse button and a blue line with 

the right mouse button. The left and right simply reflect the relative position of the two colours as shown in 

the palette indicator.  

 

This can be changed 

by left and right clicking 

in the palette indicator. 

Now a yellow line 

would be drawn with 

the left mouse button 

and a green line with 

the right.  

 
 
 
 

8.3.6 Draw / Edit 

     

Signs can be also edited using a number of drawing methods. 

Feature Description 

Freehand draw Allows freehand drawing on the sign by holding the left mouse button and dragging 

the cursor over the sign image. Holding down the right mouse button and dragging 

it over the drawn area deletes it.  

Line draw Provides for straight lines to be drawn horizontally, vertically and diagonally by 

holding down the left mouse button and dragging the cursor in the desired direction. 

Again, the right mouse button can be used to delete any drawn lines.   

 
 

 



                                                                                        HELEN Sign-editing Software – Operating Manual 

540125-18 page 110 of 199  08/11/2024 

 
 

Feature Description 

Mark text Allows selection of a rectangular area of the sign by right or left-clicking the mouse 

and dragging it over the desired area. The following actions can then be carried out: 

a) Move the selected area by: 

• using the up / down / left / right arrow keys to locate a new position for the 

area, then pressing the return key to accept it 

• dragging it with the left mouse button 

b) Invert the area (turn black dots to yellow / green / amber and vice versa) by 

• pressing Ctrl + I 

• or selecting ‘Invert Selection’ in the Edit menu 

c) Delete the area by 

• pressing Shift + Del 

• or selecting ‘Delete’ from the Edit menu  

• or pressing the delete button  

d) Using the buttons in the ‘Edit’ panel; cut  or copy  the area on the 

computer’s clipboard. It can then be pasted  to any sign and be moved in 

the same way as in a) above. As mentioned above, the selected area can also 

be completely deleted by pressing the delete button  

e) De-select the selected area by right or left-clicking the mouse in the area 

8.3.7 Super-X 

 

8.3.7.1 Super-X features 

Super-X is a tool which allows the user to add more variation in how messages are presented on a sign. It 

has a number of features which allow flexibility and scope such as: 

• Scrolling text 

• Up to four fields 

• Independent scrolling of fields 

• Left and right scrolling 

• Text justification in field 

• Ten preset field layouts 

• Programmable route number 

• Embedded graphics 

• Route number position selection 

• Automatic text sizing 

• Adjustable route number field width 
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Feature Description 

 
Scrolling can also be selected manually – even if the text would fit anyway. This 

is controlled by the arrow buttons under ‘Super-X features’. For more details, 

please refer to h) How to use Super-X in 8.3.7 Super-X. 

The flash arrow will cause the text in the field to flash. 

 
To increase / decrease the font size – the sign only has a limited number of fonts 

than can be used by Super-X and this control can only ‘ask’ for a different font (or 

font size). If it does not exist, the font will remain unchanged. 

 

To change the inter-character spacing – controlled by left / right buttons. 

 
Proportional second line – when this box is ticked, the lower field will be made one 

font size smaller (unless the smallest font is already in use). This increases the 

emphasis on the top line. 

→  

Inset the route number – to ensure that the characters (including any outline) are 

surrounded (i.e. including top and bottom) by the background colour. The indent 

button image will change when indenting is applied. 
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a) Super-X feature comparison 

Feature HELEN graphic mode Super-X 

1-line message ✓ ✓ 

2-line message ✓ ✓ 

2-line asymmetric14 msg. ✓
15 ✓ 

3-line message ✓
16 ✓ 

Text  ✓ 

Graphics ✓ ✓ 

Programmable route number ✓ ✓ 

Route number position ✓ ✓ 

Route number box width ✓ ✓ 

Justification (left, right)  ✓ 

Scrolling (left, right)  ✓ 

Automatic text sizing ✓ ✓ 

Scroll on text sizing failure  ✓ 

Continuous loop scrolling  ✓ 

b) Picture gallery 

Super-X allows information to be presented in ten different ways: the images below are examples of the ten 

modes and were generated from 128 x 17 sign mimics. 

Single line 

  

Mode 0 Mode 1 

 
  

 
14 i.e. where the top line of text is a different font size to the lower line 
15 Only if all pages on that sign are shown asymmetrically; Super-X, however, is able to show a single asymmetric page. 
16 A three-line message is possible in graphic mode: refer to Appendix H: Three-line operation for further information. 
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Two lines 

  

Mode 2 Mode 3 

  

Mode 4 Mode 5 

 

 

Mode 6  

Three lines 

  

Mode 7 Mode 8 

 

 

Mode 9  

c) How to use Super-X 

The easiest way to use 
Super-X is by using the 
features built into HELEN 
from version 2.0o onwards. 
When an LED destination 
sign is selected, the Super-
X frame will become visible 
in the sign designer form. 
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When the Super-X box is ticked, additional features become available: 

 

The most likely reason to user Super-X will be to create a scrolling field – for example, where there are a 

number of via points to be included. These can be shown on a number of pages but an alternative is to use 

a single page that scrolls. There are two ways of creating scrolling text: automatic scroll or selective scrolling. 

Automatic scroll occurs if the text does not fit into the required space. The text-fitting routine will reduce the 

font size until the smallest font is reached and, if necessary, the text will then scroll in that size as shown 

below: 

 

However, if Multipage Super-X is being used, it is important that any scrolling message is explicitly set to 

scroll by selecting the appropriate arrow (refer to Appendix P: Working with Multipage Super-X). 

Scrolling can also be selected manually – even if the text would fit anyway. This is controlled by the arrow 

buttons under ‘Super-X features’. 
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This figure shows 

the bottom line 

being scrolled. The 

top line can also be 

scrolled in a similar 

way.  

Note: The 

difference in the 

fonts used: this is 

described further 

in ‘Font selection’ 

below. 

Selecting the right-hand arrow causes text to be scrolled from left to right; this is designed for languages 

that read from right to left (such as Arabic, Hebrew etc.). Its use in standard text mode will cause the letters 

to come out in reverse order (but not back-to-front). This is not an error! It can be prevented by ‘fixing’ the 

appropriate field prior to ticking the Super-X box. 

Note: If scrolling and paging are required on the same sign, then it is best to use Multipage Super-X to 

synchronise the pages (refer to Appendix P: Working with Multipage Super-X). 

d) Font selection 

The font selection is automatic and as more text is introduced, the font size will be reduced to fit the available 

space. If the text will not fit, an automatic scroll will be activated. Under these circumstances, the text will 

be scrolled using the smallest font. If a larger font is required, simply click on the appropriate scroll box and 

the text will scroll using the largest font possible. By default, the font size of the lower field will never be set 

to be larger than that of the top field as the emphasis is usually on the main destination – and this is normally 

positioned on the top line17. 

e) Creating a Super-X graphic 

Super-X allows the scrolling of a particular field. A greater choice of sign configurations is possible e.g. route 

number plus three fields etc. However, it does not have the flexibility of the standard HELEN graphical 

editing system where a user-defined logo (i.e. a pictogram) or font can easily be created. Also, as Super-X 

only works with fonts contained in the sign, scrolling Arabic or Chinese scripts cannot currently be achieved.  

Creating a Super-X graphic combines the flexibility of the HELEN graphical system with the advantages of 

the Super-X system. 

  

 
17 If the destination is set as the bottom field, then a similar system is possible but at present, this will not be automatic 
and requires the use of manual mode.  
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Example of creating Super-X logo and text in Times New Roman font: 

1. Create or use a pre-defined logo in the same way as for a standard HELEN graphic. Notice the use of 

LOGO 16 font: the combination of this font and the character ‘A’ in the route number box will produce 

the pre-defined horse symbol18. Add the destination message – in this case, ‘Brighton Races’.  

 

2. Convert the destination message to the desired font (as described in 8.3.2.3 Selecting Windows fonts). 

This example uses Times New Roman but any font on the computer can be used. 

Note: the message can be added directly using the desired Windows font: it does not have to be created 

using the HELEN fonts and then converted. 

 

3. Tick the two check boxes labelled ‘Fix’. These are colour-coded for the appropriate fields. When a box 

is ticked, the graphical content of that field is converted to a Super-X graphic. 

4. Tick the ‘Super-X’ check box: this automatically enables the Super-X functionality for the graphic. If 

desired, the route number field can now be made to scroll left to give a representation of a moving 

horse.  

f) Creating a Super-X graphic of part of the screen 

 
18 For a full list of pre-defined symbols, refer to Appendix I: Alpha to symbol converter (Hanover fonts). 
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The original method for creating a Super-X graphic captures a particular area of the screen as opposed to 

a specific field. 

1. Ensure that neither Fix nor Super-X has been applied, then convert the desired item – in this case, the 

horse (although any part of the sign can be copied) by selecting the area ( )and then copying it  

( ). A well as copying, this action will also create a Super-X version of the image.  

 

2. Convert the sign to Super-X and tick the Manual Mode checkbox as shown below. 

 

3. Locate the position to paste in the graphic string (at letter ‘A’). 
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4. Highlight the letter ‘A’ and then paste (either right-click on the mouse and select paste or Ctrl+v). The 

screen should look like the one below: here, the Super-X message now includes a graphic string and the 

representation of the message on the mimic. If required, the horse image can be made to scroll by placing 

“\sl” between “mss1” and “{“. 

 

5. Finally, place the cursor at the end of the string and hit the return key. This will change the ‘A’ to the 

required horse as shown below. 
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8.3.7.2 Extend features 

There is also an additional checkbox for creating a Super-X graphic which is potentially wider than the sign. 

Example: 

This example will be demonstrated on a 32 x 17 Route Number sign for maximum effect. The Windows 

‘Times New Roman’ font has been selected to show the message “This is a Route Number sign” as shown 

below: 

 

This message does not fit. If ‘Super-X’ is ticked, the message will be shown scrolling in the smallest font for 

that sign configuration (auto-scroll) as shown below: 
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If the ‘Scroll’ button is pressed, the message will be scrolled using the largest font as shown below: 

 

This works but does not present the message in the selected font (Times New Roman). To use the ‘Extend’ 

feature, uncheck the Super-X box. By ticking the ‘Extend’ box, a temporary sign switch width of 300 (default 

value specified in Helen.ini) is created as shown below and the text can now tbe inserted into the new 

available width by clicking Drop. For more information, refer to ‘maxextendwith’ in Appendix B: HELEN 

initialisation file (helen.ini). 

A scroll bar is displayed below the preview. It allows the user to scroll from left to right for a complete preview 

of the text which starts on the left hand side. 

 

Note: the red line is to indicate the actual sign size.  

Once ‘Fix’ has been ticked (to create the Super-X graphic – effectively taking a snapshot of the message), 

‘Super-X’ can be ticked. The text will scroll automatically in the desired font if it does not fit (as shown below) 

and can be made to scroll using the left / right arrows (refer to 8.3.7.1 Super-X features) if it does.  

Notes:  

• if the ‘Fix’ button is not ticked, the message will scroll in the original Hanover font.  

• the order of the keystrokes in this process is critical to it producing the required outcome. A similar 

example is summarised in Appendix K: Programmable route numbers. 
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The amount of information used to create the message can be viewed in Manual mode – refer to above 

figure. Because of the way it works, the Extend feature will increase memory usage and can slow down the 

system, so this technique should be used sparingly. 

 Manual mode 

The features within Sign Designer accessed from the buttons and menus etc. are used to create the signs 

required and this will be sufficient for most users. The ‘coding string’ that represents a particular sign can 

be viewed by ticking the manual mode box. However, certain settings can only be made by entering specific 

characters directly into the code: in these cases, the box must remain ticked or the added information will 

be lost. A warning dialogue box is displayed as shown below. More detail about manual mode is given in 

Appendix M: Super-X in more depth. 
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9. Hanover Technical Support 

Please do not hesitate to contact Hanover Technical Support located in Lewes, UK for any problem 

encountered or for any advice needed for using the HELEN software: 

Contact 

Phone +44 (0)1273 477528 Ext.615 or Option 2 

Email support@hanoverdisplays.com 

 

 

mailto:support@hanoverdisplays.com
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Appendix A: Uninstalling HELEN software 

The current HELEN installer will not allow more than one version of HELEN to be installed on one machine.  

Do not attempt to overwrite the old version of HELEN with a new one in the same folder, as the results are 

unpredictable. 

A number of extra files are installed to keep a watch on the HELEN installation.  If a HELEN system file is 

removed accidentally, the installer will automatically correct the error.  It is therefore important to uninstall 

the software correctly (i.e. do not just delete the directory) otherwise the files will be reinstalled automatically. 

If customised font files like 'eurofont.fdb' or any other file with suffix 'fdb' are to be retained, copy them into 

a separate folder outside the current HELEN directory.  Depending on the operating system in use, the 

location of these files will be in the following folder: 

• Windows 7 or later: Program Data\Hanover Displays\Helen 

With current versions of HELEN, it is possible to uninstall the program from the Windows Start Program 

Menu as shown below: 

 

For previous versions: go to Start → Settings → Control Panel and click on 'Add or Remove Programs' as 

shown below.   

 

Select Helen and click Remove. 

The next step removes any subdirectories or font files that were part of the installation of the older version.  

Click Yes to continue un-installation. 

The installer19 will also automatically detect any pre-release (beta) versions of the software and either show 

the "Another version of this product…." message  

 

 
19 The new installer (used from version 2.0+) cannot recognise previously installed versions of HELEN and will cause 
conflicts if the old version is not removed 
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or the 'Repair / Remove' form as shown below if an attempt is being made to reinstall the same version of 

the software.  When the old version has been removed, the installation process must be restarted.  Note 

the 'Repair' option will re-install any program files that have been corrupted. 

 

If HELEN has been removed using the 'Remove' option shown above, the following window will appear after 

the un-installation process finishes to indicate that HELEN has been uninstalled successfully.  If 'Add or 

Remove programs' has been used as shown above, then no message will appear. 

 

If customised font files have been saved in a separate folder, remember to copy them to the directory where 

HELEN is installed after the installation process is complete. 
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Appendix B: HELEN initialisation file (helen.ini) 

The file named helen.ini contains the initialisation details for the HELEN program. The terms marked with a 

grey background would normally be set by the program and not normally changed by the user. The terms 

marked with a green background would not normally be adjusted by the general user. 

 

 

 

To edit helen.ini20:  

Depending on the operating system in use, the location of this file will be in the following folder: 

• Windows 7 or later: Program Data\Hanover Displays\Helen 

which in both cases may be a hidden folder. 

However, the easiest way to modify the file is to use the edit button found on the configuration form.  Open 

the form via Options → Configuration: 

                                    

This button will automatically find the correct location of the file.  Please note that some of the changes will 

need a program restart to take effect.   

  

 
20 Previous to HELEN version 3.1, helen.ini would have been located in the application folder.  This caused problems 
with Windows 7 or later as any edited file would be copied and moved off to a virtual folder to become the working file. 

Caution should always be exercised whenever any changes to the helen.ini file are made. 
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The terms within the helen.ini file have the following meanings (text in [square brackets] relates to the 

section within helen.ini): 

Term Meaning 

[setup]:  

uploadport 
Sets the default port for loading a dataloader (see key-lo below) or using 
the ‘messages’21 facility on preview. Default =1. 

Note: When using ‘messages’, the maximum port value is 16 – however 

when loading a controller, the max value is 256.  

datapathspec Name of the folder where the last database was accessed. It will 

automatically be set by HELEN (no default). 

lastdatabase Name of the last database accessed. It will automatically be set by 

HELEN (no default). 

LastSaveAsFileName Name of the last database saved using the 'Save As' feature. It will 

automatically be set by HELEN (no default). 

NoSignSize Is set to stop the addition of sign sizes in the eric.bin. This is a back-

compatibility feature and the default setting = False. 

NoVEparameter Is set to stop the addition of VE parameter in the eric.bin. This is a back-

compatibility feature and the default setting is False.  

FullColourDefault 
Default colour value for a full colour sign (R, G, B).  

(255,170, 0): original default amber colour for a full colour sign. 

PresetInfoMsg 
Feature to allow up to 4 Info messages (out of a choice of 10) to be added 
to specific routes at design time – Originally required by KMB (default 
setting = False). 

Refer to Appendix O: Pre-Set Information Messages. 

SxMultipage Feature to allow Super-X pages to be combined to allow pages to 

synchronised and with accurate page timings. (default setting = False 

because the correct version of sign software needs to be used). 

SpecialRNwidth 
Special value associated with processing sign #0 of a KMB database 
with a right-hand route number and will determine the space used by the 
contents of the route number field. Using regeneration, it will update 
RNwidthused but does not create a new graphic (for retro-fixing an 
existing database). Used to enable the generation of header data for 
pasting the graphic of a route number into an information page. Do not 
remove ‘//’ unless you need this special feature – KMB only. 

‘Regenerate Text on Blank Signs only’ needs to be set when 

regenerating (will stop the sign being blanked).  

shownRNwidth When shownRNwidth is true, a vertical white line will show the width 

used by the route number field.  

MaskIgnore This will set the number of characters in the route number field that will 

cause the column masking to be ignored i.e. if set to 1, then a single 

character in the RN field will have masking (if set) but two or more 

 
21 If the ‘Messages’ checkbox (in the Preview screen) does not appear, the upload port setting in the helen.ini file is not 
set.  If the ‘Messages’ checkbox does appear, there is the option to view the message directly on the sign itself.  To do 
this, an RS232-485 converter and a lead connecting the PC to the sign will both be needed. 
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characters will use the space reserved for masked columns. This feature 

is switched off if set to ‘0’. (Default Off)  

enableTextMode Will enable signs other than internal LED to work in Text Mode  (default 

setting = False). 

Link The default setting for Super-X generation i.e. between Link2 and the 

setting here. Standard setting is ‘1’ but ‘0’ used for RATP. 

ThirdLineMarker Is a special character or character string that determines if three-line 

mode is used. This is specifically designed for HK but can be used for 

any sign high enough to support three lines. 

ThreeLineTopBoxHeight_n Defines the allocation of the height of the top field height when using 

three-line mode. These allocations will override the sign configuration 

settings. 

SuperXdefault When set to true, all Super-X capable signs will default to Super-X and 

not to graphic mode (default False – Graphic Mode). 

MsgSpeed Will set the comms speed when sending messages to the sign directly 

from HELEN. This parameter will normally be commented out as the 

system will default to 4800 if this line is missing.  

MsgBinary Used to set messages (see above) to output as binary format. Default is 

False and is therefore normally commented out. 

keylo 

  

Base address of Key-Lo base station. Program will search for a base 

station at this address. If not found, then the uploadport value will be 

used instead. If this is not a valid port, then port 1 is used.  

fontfile 
Defines which font database is to be used. Eurofont.fdb is the standard 
database for European fonts.  

Arabfont.fdb contains fonts that are required for Arabic support and 

Chinfont for Chinese support (default = eurofont.fdb).  This will define the 

default value which can be changed in the program. 

ArabicFontName This used to be ‘Simplified Arabic’ and fixed in the code but stopped 

working with Window 7. Now brought out to .Ini file for any future 

problems.  

residualspace Is the minimum number of spaces left, after the text has been dropped, 

before the text will be RH justified in a SINGLE_RN. This is to ensure 

that the maximum space available is used to separate the RN and 

destination.  

ericidlen Is the length that the destination ID code should be in the controller. This 

should be either 4 or 10 depending on the software in the controller. 

However, this value can be altered within the program (default = 10). 

maxsigns Determines how many signs HELEN can support.  This can be up to 16, 

and again is dependent on the controller software (default = 16). 

maxsignpages Specifies the maximum number of pages shown (default = 16; max 999). 

maxledgrwidth 

 

Maximum width of an internal LED sign (default = 255). This value should 

be made no bigger than ‘maxextendwidth’.  

maxextendwidth Maximum width that the sign can be extended to create a Super-x 

graphic (default = 300). 
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ledsigntype 
LED sign type used for Adverts / Stop Lists: 

0 - ANSI, 1 - Upper & Lower Case,  2 - Upper Case (default = 1). 

KarlstadOutlineType 
The Outline type value is used to switch on the special outline feature 
required by Karlstad buses (Sweden).  

1=Standard outline of RN (default), 2=Special outline to the left and right 

of brackets (16-19), 3= Combination of 1 & 2. 

FullOutline Used in NYCT to fully outline the text – previously the corners of the 

characters would be left without outline. This is a switch on feature until 

Super-x is brought into line (True/False). Default = False. 

FrameEnable Is a switch on feature to enable multipage messages to be sent to a sign 

– first used with NYCT full colour signs with enhanced memory. Normally 

switched off as this feature is presently (July 2016) not available in 

standard signs.  

Disable_FC_Offset Full colour sign adjustment to switch off the two-column offset NYCT. 

Default = False.   

TwoLineLock  Will allow two line graphic to be made into a left-aligned synchronised 

Super-x message. Specifically designed to scroll Chinese and English 

messages so generally disabled unless required (True/False). Default = 

False. 

driverLowerCase With 'driverlowercase' set to '1', it will allow driver’s messages to have 

mixed case – ‘0’ will give only uppercase characters.  

DriverRemapEnable When set to 1, will allow re-mapping of the character set used for the 

driver's message on the controller. This will enable accented characters 

to be shown to their nearest equivalent.  The substituted characters are 

defined in dremap(x) (x default = 1). 

ConsoleConfigDisable When set to 1, the Controller Config menu will be disabled (default = 0). 

ConsoleEditDisable When set to 1, the Controller Edit menu will be disabled (default = 0). 

Duty 
Two values to set the flash parameters of a Super-X field. These two 
values are combined as follows: 
N = (Duty * 100) + Period 
Duty =1-9 (10% - 90%). Default 0 = 50%. 

Period = 1-99 1/10ths second. Default 0 = 10 (1 second). 

Period 

Compression_n 
List of compression strings. Need to be in contigeous order from 0 (no 
compression), 1 (standard compression) etc. 
These should not be changed without good reason. 
Note: compression_0=-q will stop the sign sizes being added to the 
uncompressed eric.bin.  
Note: compression_2=-j” - D -S -Z2,15 -L2, 15 -V” will give a verbose log 
file compression_2= -j” - D -S -Z2,15 -L2, 15” 

Compression_3 is zlib 

PlainFile When set to True, it will cause Sendwrap to transfer an uncompressed 

file which can be useful if the file is big and the controller does not have 

sufficient space to uncompress or when sending to an old Eric via a Key-

lo (default = False). 

ProgRNbackCompat This feature will ensure backward compatibility with older versions of 

HELEN. The combination of a single ‘%’ character in a SINGLE_NONE 

configuration will cause the ‘%’ to be written to the database in TEXT 
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MODE. This will ensure that the controller will recognise it as a 

programmable route number (will set the -% switch to Database.exe). 

This feature was originally set automatically, however, it creates a 

problem for Multicolour RN signs as it puts it into text mode and removes 

any colour info. In discussion, it appears that this feature is not actually 

required and has therefore been switched off. For safety, it can be re-

enabled if required by setting ‘True’ (default = False). 

Delimiters The delimiters are used when turning text in 'Title Case'.  Use a pipe 

character '|' to delimit this list (a space character is automatically included 

as a delimiter in the actual list). Delimiters=  -|.|,|~|/ 

exceptions 
List of exceptions used when setting text into title case. Word will be 
reproduced exactly as shown.  

Exceptions= via, on, by, upon, under, ASDA, COOP, NEC, NIA, ESCC, 

de, du, a. 

autofonts_n 
This is the list of suitable fonts for a particular sign height that the ‘Select 
Standard Fonts’ button will use. This list can be edited but must not 
contain more than 20 for any sign.  
The 'n' indicates the height of the sign  

(i.e. autofonts_16 for a 16-high sign).  

autofonts 
This list is used if a specific autofont_n list is missing (i.e. a 16-high sign 
is selected but autofonts_16 is unavailable). 
 
If an autofont is not available for a particular sign height, the program will 
choose from the list below (no more than 20). 

Autofonts=0705C1E1,0705N1E1,0708B2E1,0806C1E1,0808B2E1,141

0C2E1,1411B3E1,1608C2E1,1610N2E1,1613B3E1 

autoRNfonts_n 
This is the list of suitable fonts for a particular sign height that the ‘Select 
Standard RN Fonts’ button will use. This list can be edited but must not 
contain more than ten for any sign.  

The 'n' indicates the height of the sign (i.e. autofonts_16 for a 16-dot-

high sign).  

autoRNfonts 
This list is used if a specific autoRNfont_n list is missing (ie a 16-high 
sign is selected but autoRNfonts_16 is unavailable). 
 
If an autofont is not available for a particular sign height, the program will 
choose from the list below (no more than 20). 

autoRNfonts=0708B2E1,0808B2E1,1110B2E1,1411B3E1,1513B3E1,1

613B3E1,1713B3E1,1912B3E1,2430N4R1,3015B3E1 

altChineseAutoFonts 
and 

altArabicAutofonts 

New system adopted with HELEN v2.0o has a separate alternative list 

of fonts for Arabic and Chinese. The presence of an Arabic or Chinese 

keyboard will make the selection automatically. 

UserFile Defines the name of an optional user binary data file. Create and save 

the file in the usual directory and substitute the word "User" for the name 

chosen for this file. Then on the SAVE OUTPUT FILE form, click the User 

checkbox. The user file data is then appended to the end of the eric.bin 

file (default = user.bin). 

MaxDrvLen Determines the maximum length of the driver's messages.  Note: some 

controllers are unable to support a length greater than 16 (default = 16). 
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disableinterpolate If set to 1, it will disable the automatic insertion of preamble references 

(default = 0). 

NoFirstDrvMsg Determines which pages of the driver message will be shown.  It defaults 

to 0 - this will show all pages. If this is set to ‘1’, then the first driver msg 

will not be put in the eric.bin.  

ContainerFileEnable 
If set to '1', it will enable the creation of container files (default = 0). 

Note: At present, container files and compressed files are mutually 

exclusive. If container files are set, then the createcompressedfile flag 

will be ignored. Also, the Save-As feature is disabled when container files 

are enabled. 

NoConfirm When set to 1, it will remove the need for confirmation (i.e. clicking OK) 

when downloading to a controller (default = 0). 

Polling When set to 1, it will enable polling. This obviates the requirement to set 

the dataloader to 'Loading' (default = 0). 

finalspeed Will set the final negotiated speed between HELEN and the controller. 

Can be useful if there is a problem with the controller.  Not normally 

required and therefore commented out. 

OldSwGui A backward compatibility measure to use the old SwGui should 

unforeseen problems occur using the new system (True/False). Default 

= False therefore commented out. 

SpecialAlign Special alignment overrides the default alignment (centre) of the 

destination fields (Left/Right/Centre{Default}). 

sxGraphicNoTrim Will turn off the trimming of any white space from the creation of a Super-

X graphic (True/False). Default = False, i.e. it will trim by default. 

sxBlankCols This will set the number of blank columns between the route number field 

and the destination field(s) (default = 2: Value limited between1-9). 

Original Graphic mode has a set value of 1. 

dremap(x) See DriverRemapEnable. 

AdvertUpperCase Section to sort out limitations in advert processing. Until this change, 

control characters were always converted to lower case. This caused 

problems when a capital 'P' is used to try and create a long delay.  To 

avoid back compatibility issues, the lowercase conversion will be 

maintained unless explicitly switched off here.  'AdvertUpperCase' is 

False by default and therefore commented out. 

AdvertExtraControlCharacters Extra control characters can be added to avoid unknown characters 

being ignored. 

MaxMsgIdDigits 
Determines the number of message pages that can be shown.   

It defaults to 2 giving a maximum number of 99 (i.e. MaxMsgIdDigits=2: 

01 to 99). This can be changed to 3, which will give a maximum number 

of 999 (i.e. MaxMsgIdDigits=3: 001 to 999). Note: 3 digits not yet 

supported in controller - do not change without reference to Hanover 

Displays. 

Addconfigparams 
When set to 0, it will ensure the configuration box is unchecked within 
‘Save Output File’ form.  

Default = 1 for checked.  
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Createcompressedfile When set to 1, it will create a compressed version of the eric.bin 

(Eric.Whf).  Note: At present, container files and compressed files are 

mutually exclusive. If container files are set, then the 

createcompressedfile flag will be ignored.  

Customcolours List of extra colours that have been selected by the user (automatically 

set). 

LastTTfontName Last selected Windows font (automatically set). 

LastTTfontBold Weight of last selected Windows font (automatically set). 

LastTTfontItalic Set if the last selected Windows font was italic (automatically set). 

inhibitSXenhancedColourFeat

ures 

Will restrict the generation of any Super-X outline to either black or white 

and will inhibit the generation of the enhanced colour system for Super-

X (default = False). 

RegenSideSignWithTT Will enable TT (true type) fonts to be regenerated into a side sign. 

Normally not recommended so disabled by default (True/False). Default 

= False. 

maxstripetype Specifies the maximum number of stripe types for colour signs (if 

missing, then the default = 15). Note: default has been increased to 19 

for Karlstad.  

support=support@hanoverdis
plays.com 

backup=backup@hanoverdis
plays.com 

supportsubject=Support Helen 

backupsubject=Back-Up 
Helen 

supportfilename=Support.Zip 

backupfilename=BackUp.Zip 

E-mail addresses for Hanover Support and Backup. Only to be changed 

by Hanover Displays. 

LastRatpProject= 
Sendername= 
Sendercompany= 

Sendertelephone= 

Automatically filled in by the program. 

[Recent Files]  

MaxNumberOfRecentFiles Displays the maximimum number of recently used lists that will be 

displayed (default = 10). 

RecentFile_n List of recently used lists (where n is a number from 0 to 

(MaxNumberOfRecentFiles-1)). 

[language]  

lang Describes the language to be used in the program. It is based on the 

international telephone dialling code. This can be changed within HELEN 

via the 'Language' option (default = 44). 
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langfallback Will set the fallback language if a translation does not exist. This can be 

switched off by either removing or commenting out the line or setting to 

‘0’ (zero). 

[convert]  

Translate Only to be set by Hanover 

Conv1 Only to be set by Hanover 

Out to Return Only to be set by Hanover 

Conv2 Only to be set by Hanover 

[display]  

pagespeed Length of time (in 1/10ths of a second) that each page of a scrolling 

display is shown in the preview window. Note that the real-time page 

duration is determined by the controller (default = 30, i.e. 3 seconds). 

[UnicodeFontBlocks]  

ActiveFonts Basic Latin, Coptic, Cyrillic, Greek and Coptic, Latin Extended-A, Latin-

1 Supplement 

[signtypes]  

sX 
The [signtypes] section contains all the display types that are available 
in HELEN.   

sX = name, width, height, code, features where X is a decimal number 

starting at 1. 

[console] 
 

protocols 
Contains a list of the selectable protocols22 available for the controller. 

sign_params 
Contains a list of selectable sign parameters23 (profile editing). 

 

  

 
22 List of protocols: SIGN, DIAG, TERM, AACHEN-IBIS, AESYS-A, ALMEX, AUBAGNE, BEEP, BKB, BKBCORUNA, 
BKBDIG, BKBMAT, BKBSANTANDER, BKBVALENCIA, BLUETOOTH, CAMP-Pulse, CAPETOWN, CFL-IBIS, CGA_A, 
CIBOR, CIBOR-2, CIBOR-3, DECT, DUBWAYF, DUHAMEL-A, ELECT-A, ERG-A, ERG-B, ERG-C, ERG-D, GPS, 
GPSLOG-GPS, GPSLOG-LOG, GTMH-1, HANO-1, HANO-2, HANO-1F, HANO-2F, HANVOX, HCPS, HIAWATHA, IBIS-
2, IBIS-3, IBIS-4, IBIS-5, IBIS-6, IBIS-TV, IBIS-VMX, IBIS-WL, IBIS-ZZ, IBISSANTANDER, IBPERUGIA, INEO-A, INTRA-
TCRA, ISR-1, J1708-1, J1708-2, J1708-2A, J1708-3, KOR-1, KOR-2, KOR-3, KOR-4, MONET-A, MONET-B, MS, 
MURCLOAD, MURCLOAD19, NETNCE, NYCT, OCTA, OPTILE, PRODAT-A, PRODAT-B, RELAY, RGLIT, RSL, SEMA, 
SEREL, SLE, SOCRIE-A, SOCRIE-B, SPEC-A, SPEC-B, STAAB-IBIS, STP403S, SYSECA-A, TERNI, TGX150-A, 
TGX150-B, TGX150-C, TGX150-D, VDV-IBIS, VIGIE-ALOG, VIVA1 
23 Sign_params = -,*,0,1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,RN,HANCIS,HTC,HV,NN,XN,@ 
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Appendix C: Container Files 

Appendix C-1: What is a container file? 

A container file is an output file generated by HELEN which contains a set of message binary files (Eric0.Bin, 

Eric1.Bin etc).  Each message file is intended for a specific set of signs fitted on a vehicle.  The container 

file is loaded into the dataloader / Key-lo and then only the message file pertaining to that particular display 

set is transferred to either the Deric+ or Eric++ sign controller24. 

Appendix C-2: Why use container files? 

Without a container file, there are two options for a fleet of vehicles with different sets of signs: 

• create a separate destination list for each type of bus and load each into a separate dataloader.  

• create a single destination list which includes all the sign variants; then by using the profile technique, 

select the appropriate profile number. This option results in a much larger database being created 

than each bus actually needs. 

The Deric+ controller has a maximum of about 650k bytes of available memory. However, if there is a wide 

range of different signs together with an extensive destination list, this is not enough memory to hold a single 

HELEN list. 

With the use of container files, each controller only accepts the data that it needs, but the user can still keep 

all the message data for all the sign types in one destination list directory - as in the second option above.  

In this way, only one list has to be created and maintained and a significant amount of memory space in the 

controller is saved. 

Appendix C-3: Configuring HELEN to create container files instead of normal Eric.Bin files 

A container file can only be created if profiles have been set up (see section c) in 7.2.1.8 Signs.   

From the main destination list window, select Options → Configuration → Output File Creation → Container 

(see section 7.2 Options menu).  A container file will then be created. 

For each profile there will generally be an Eric#.Bin, where # corresponds to the profile number (profile 1 

will create Eric1.Bin etc.).   

Note: if the container file option is not selected, there will only be a single Eric.Bin file, regardless of however 

many profiles there are. 

Appendix C-4: Establishing that HELEN has created a container file 

When 'Save Output File' is selected, there will be a list of all the files that have been created. 

          

 
24 Any sign controller that can be loaded by a USB memory device has more internal memory and doesn’t need this 
technique 
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The figure on the left shows confirmation that a standard, single Eric.Bin file has been created whilst the 

figure on the right shows that a container file with three files has been created corresponding to three 

profiles25. 

When ‘Options’ followed by ‘Configuration’ are then selected:  

 

• If standard container files are required, refer to a) Standard container files. 

• If profiles are required for container file loading, refer to b) Selecting profiles for container file loading. 

a) Standard container files 

When ‘Container’ followed by ‘OK’ are selected:  

 

Note: For more details about the ‘Configuration’ tick box  , refer to b) Selecting profiles for 

container file loading. 

  

 
25 The number of files produced will actually depend on the configuration settings.  If the display allocation is the same 
between profiles, then an extra Eric#.Bin file will not be produced as this would contain duplicate information. 
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When ‘File’ followed by ‘Save Output File’ are selected, the following window will be displayed: 

  

When ‘OK’ is selected, the following figure confirming that multiple Eric.Bin files has been created, will be 

displayed:  

 

Below shows a special case where only the configuration is different. ERIC2.BIN contains the same data 

for profiles 2 & 3. This will be handed automatically when using a Key-lo. 

 

 

When ‘File’ followed by ‘Send Output File’ are selected, the Key-lo can now be loaded in the normal way.  

Note: Ensure that the controller has the correct profile set before plugging in the Key-lo. 

Now proceed to section Appendix C-5: Downloading a container file. 
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b) Selecting profiles for container file loading 

In extreme case, the Key-lo may not be able to hold all the data of all the profiles. One way around this 

problem is to only store the appropriate profiles for particular vehicle type e.g. one Key-lo will be loaded with 

the profiles for all double deck buses and another Key-lo would be used to store the profiles for all single 

deck buses. This method will still allow one list to be maintained. 

Example of list with 5 profiles: 
 

 

This time, the ‘Configuration’ box will need to be ticked followed by ‘OK’: 

 

When ‘File’ followed by ‘Save Output File’ are selected, the following window will be displayed: 
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When ‘OK’ is selected, the following figure confirming that multiple Eric.Bin files has been created, will be 

displayed:  

 

When ‘File’ followed by ‘Send output file’ are selected, the following window will be displayed: 

 

The available profiles will be displayed in the ‘Profile’ frame on the right hand side.  

On the left hand side there are 8 available presets. These presets will allow for easy selection of frequently 

used combinations. 

Note:  
i. The name of the preset can be changed by double-clicking on the preset name: 

 
 

ii. The desired preset name can then be entered: 
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iii. This process for further preset names can be repeated if required:  

 

 
Two examples of how the preset feature can be used are as follows: 

• Example 1: Preset 0 will be used to create a container file with profile #0 and profile #2. 

Note: the preset name ‘Preset 0’ will be in bold once a profile has been selected.  

 

• Example 2: Preset 1 will be used to create a container file with profile #1, profile #3 and profile #4. 
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The normal File Load dialogue will then be shown. Now proceed to section Appendix C-5: Downloading a 

container file. 

Appendix C-5: Downloading a container file 

Once ‘OK’ is selected in the above ‘Profile’ window, the SendWrap window will be displayed: 

 

Plug the Key-lo into the base station and the transfer will automatically start.  

There are two standard methods of loading a sign controller and both will support container files: 

• Loading a Key-lo from the computer running HELEN and then load the controller via the Key-lo. 

• Via a Deric+ or Eric++ configured to be a dataloader26 

The key to using a container file is the profile setting on the controller. The profile number will extract the 

appropriate part of the container file required for that unit (the example is for a Deric+ but would be similar 

for an Eric++). 

Go to 'System' on the controller (if necessary, refer to the particular controller manual) 

 

and press the F/E key until PF is shown. 

 

Use the left arrow key to select the Profile number which can be in the range 0-15 (default = 0). 

Notes: 

• When using a Key-lo, the loading will be automatic. 

• When loading an Eric or Deric as a dataloader, the dataloader may also need to have a Profile Number 

selected.  This profile number needs to correspond to a profile that actually exists (it doesn't matter 

which one).  So for the example in the above figure, a profile setting of 1,2,3,4,5 or 6 will work but not 

the default 0. 

  

 
26 This is an obsolete method and Key-lo loading should always be used in preference.  
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Appendix D: Route Browse 

The route browse system uses a route code as well as a destination code and groups all destinations for a 

given route together.  The simplest example is a bus that shuttles between two destinations, e.g. route 28 

goes from Brighton to Ringmer and from Ringmer to Brighton - same route number, two destinations.  

However, some journeys terminate at other places (Lewes, Uckfield and Tunbridge Wells, for example).  

The advantage of Route Browse is that the driver can enter the route number and then need only to use the 

up / down keys on the controller to select the required destination - the browse will be limited to the 

destinations on that route. 

To enable Route Browse: in the Destination List, go to Options → Console config. (then select relevant 

profile) → Modify → Advanced and tick the Route Browse checkbox in the profile configuration as shown 

below. 

 

Then click OK and OK to return to the main window.   

Click New to show the route and destination codes (four digits in each) in the 'Enter Route Code and Name' 
window as shown below. 

 

After entering the details for various destinations, click OK and ‘re-load’ the list by selecting File → Load. 
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The list will now show separate fields for route and destination as shown below: 

 

• Adding Route Browse later 

It is possible to add the Route Browse feature to a destination list that has been built without it. 

 

This figure shows an extract from a destination list 

before Route Browse is deployed: 

 

 

 

 

 

 

 

 

 

This figure shows the same list afterwards, when the box 

‘Route Browse’ shown above is ticked: 

 

The route code field of each destination list item can now 

be modified manually by incorporating the route number 

via the Edit function. 
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Appendix E: Working with Arabic characters 

From HELEN version 2.0o, there are two methods of implementing the Arabic writing system.  The original 

method uses specific Hanover fonts which are often useful if there is a lack of space.  The newer method 

uses the Windows font system to render the characters.  This appendix describes both methods.   

Note: Hanover fonts give a better result on a smaller sign and take up less space. 

Appendix E-1: Hanover font system 

The Arabic auto-font selection works in a slightly different way to the standard European auto-font selection.  

Fonts are selected from an alternative font list (found in the helen.ini file) when a text entry box is marked 

as Arabic. The marked box will be evident by having a light brown background colour 

To mark a text entry box as Arabic, simply click in the box, select the appropriate keyboard as shown below 

and enter the required text.  Similarly, to change the language applicable to a box, delete any text present 

and select the required keyboard afresh.  Depending on the PC's settings, toggling between keyboards can 

be done using Alt+Shift. 

 

Once a box has been marked for a particular language, the appropriate keyboard will be automatically 

selected for that text box when editing. 

For users of Windows 7 or later, the standard operating system can be extended to allow the use of Arabic 

operation.  First, check to see if the required language is already installed: select Start → Control Panel → 

Region and Language. 
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Next, click Change keyboards… to install an appropriate keyboard as shown below: 

 

Note: The correct keyboard may already be installed, in which case this stage may be omitted.  
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Click Add to add an appropriate Arabic keyboard such as Arabic (Saudi Arabia) as shown below: 

 

The following selections have been used successfully but other configurations will be possible. 
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After choosing the required keyboard as shown above, click OK and from the following window, select the 

'Administrative' tab to set the correct code page. 

 

Select ‘Change system locale…’ to change it as shown below: 

 

Click OK and the language/keyboard installation should be complete. All that remains is to select the 

required font file. 

• Selecting a font file 

HELEN is supplied with a number of font files. The default fonts are contained in a file called Eurofont.Fdb 

and this, as the name suggests, contains the fonts required for the major European languages.  Other files 

are included to support the specific requirements of particular customers or particular language systems, 

e.g. Arabfont for Arabic writing systems.   
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Prior to HELEN v2.0o, the various font files were selected by editing the helen.ini file but this can now be 

done via Options → Configuration from the Destination List screen as shown below. 

This setting will be retained with the 

database and will automatically be set 

when the database is reloaded. 

That concludes the setup process; 

European or Arabic characters can now 

be entered normally into the relevant 

text boxes.  Remember, to select a text 

box as Arabic, simply insert Arabic 

characters.  Once selected, the 

keyboard will automatically change to 

the appropriate language. 

 
 
 
 
 
 
 
 
 

Appendix E-2: Windows font system 

The great benefit of this system is its ability to take advantage of the numerous input methods and fonts 

available with Windows.  Apart from selecting a font file as shown above, the settings required are the same 

as for the Hanover font system.  The Windows font system can be identified by the light blue background 

colour as shown below: 

 

On the Sign Designer screen, tick the  box: the text entry box will become light blue.  
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Then click Font to select an appropriate font from the figure as shown below: 
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Appendix F: Working with Chinese characters 

From HELEN version 2.0o, there are two methods of implementing the Chinese writing systems.  The 

original method uses specific Hanover fonts which are often useful if there is a lack of space.  The newer 

method uses the Windows font system to render the characters.  This appendix describes both methods.   

Note: Hanover fonts give a better result on a smaller sign and take up less space. 

Appendix F-1: Hanover font system 

The Chinese auto-font selection works in a slightly different way to the standard European font selection.  

Fonts are selected from an alternative font list (found in the helen.ini file) when a text entry box is marked 

as Chinese.  The marked box will be evident by having a light brown background colour as shown below: 

 

First, check to see if the required language is already installed: select Start → Control Panel → Region and 

Language. 
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Next, click Change keyboards… to install an appropriate keyboard as shown below: 

 

 

Note: The correct keyboard may already be 

installed in which case this stage may be 

omitted.  

Click 'Add' to add a keyboard. 
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For users of traditional Chinese characters the following can be recommended (it may be that other 

configurations are possible but the following have been used successfully): 

 

Select 'Chinese (Taiwan)' and a number of different entry methods can now be selected.  Choose the most 

suitable method as shown above.  Click OK.  

The new keyboard(s) will now be shown as follows: 
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If required, click 'Properties' with the appropriate Chinese keyboard highlighted. The following figure shows 

the properties page for the New Phonetic IME. 

 

Select ‘Character Set…’. 

The following ‘Character Set Settings’ window will be displayed: 

 

As the HELEN font system will only work with the Big 5 character set, ensure that the 'BIG5 characters 

only' box is ticked (see later in this document for Hong Kong Supplementary Character Set). Click OK, which 

will bring back the ‘Text Services and Input Languages’ window.  Click OK again which should cause the 

‘Reglion and Language’ window to re-appear. 
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Now select the 'Administrative' tab to set the correct code page. 

 

Select ‘Change system locale…’ to change it as shown below: 

 

This part is important as the HELEN program does not have Unicode capability (and all Chinese characters 

entered will appear as a '?'). Just select 'Chinese (Traditional, Taiwan)'. Click OK and the language / keyboard 

installation should be complete. 

There should now be a language toolbar present on the screen as shown below: 

 

Characters can now be selected by a variety of methods (a couple of examples are shown). 
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The IME pad option will be as shown: 

 

Or Cangjie: the following window shows the result of entering 'L' …. 

 

…. and the following window shows the end result once the character has been 'dropped': 

 

Remember, to select a text box as Chinese, simply insert Chinese characters.  Once selected, the keyboard 

will automatically change to Chinese. 
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Note: When the language toolbar is minimised, the right hand side of it can sometimes disappear.  This means 

that the complete bar cannot be accessed.  If this is a problem, simply 'Restore the Language bar' (right-click) 

and the complete language bar will be available.  Depending on the PC's settings, toggling between keyboards 

can be done using Alt+Shift. 

• Selecting a font file 

HELEN is supplied with a number of font files.  The default fonts are contained in a file called Eurofont.fdb 

and this, as the name suggests, contains the fonts required for the major European languages.  Other files 

are included to support the specific requirements of particular customers or particular language systems - 

e.g. Chinfont.fdb for Chinese writing systems.  Prior to HELEN version 2.0o, the various font files were 

selected by editing the helen.ini file but this can now be done via Options → Configuration from the 

Destination List screen. 

 

 

This setting will be retained with the database 

and will automatically be set when the 

database is reloaded. 

 

 

 

 

 

 

 

• Hong Kong Supplementary Character Set (HKSCS) 

Customers in Hong Kong will probably need to use characters in addition to the Big 5 set: these are 

contained in the Hong Kong Supplementary Character Set (HKSCS).  HELEN can work with these additional 

characters but, to enable the HKSCS to function, support needs to be downloaded from the Microsoft web 

site to ensure that the required font (MingLiU_HKSCS) is available. 

www.microsoft.com/hk/hkscs/default.asp. 

As described on the linked page, there is a possibility that existing destination lists will include user-defined 

characters which are impossible for the system to recognise.  In these cases, the system will produce a '?' 

in the text box but the sign itself may show the correct character.  

  

http://www.microsoft.com/hk/hkscs/default.asp
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Appendix F-2: Windows font system 

The great benefit of this system is its ability to take advantage of the numerous input methods and fonts 

available with Windows. 

 

The Windows font system can be identified by the light blue background colour. 

To include the appropriate Supplementary Language Support, select Start → Control Panel → Region and 

Language. 

The appropriate keyboard can now be added. Chinese (Simplified, PRC) is suitable for simplified Chinese 

characters as shown below. 
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Next click "Properties" with the chosen keyboard highlighted as shown below: 

 

The following window shows the settings that can now be set to the user's preferences: 
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After choosing the required keyboard as shown above, click OK and from the following window, select the 

'Administrative' tab to set the correct code page. 

 

Select ‘Change system locale…’. 

HELEN is not Unicode-compatible, so the appropriate code page needs to be set.  To match the keyboard, 

'Chinese PRC' needs to be selected as shown below:  which will require a computer restart as shown below: 
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This will require a computer restart as shown below: 

 

There should now be a language bar on the screen. The figure below shows a 'restored' language bar. 

 

On the Sign Designer screen, tick the      box - the text entry box will become light blue. Then click Font to 

select an appropriate font as shown below: 

 
The following windows show some font options (Simsun & Arial). The system works without choosing a 

specific Chinese font. 

  

Now the required Pinyin can be entered into the text box: see the example below: 

 
  



                                                                                        HELEN Sign-editing Software – Operating Manual 

540125-18 page 159 of 199  08/11/2024 

 
 

If the space bar is pressed, the Pinyin will be converted into a simplified Chinese character (or a choice of 

glyphs depending on the settings as shown below: 

 

After selecting the appropriate Chinese character, it should now be shown as follows: 

 

This process is continued until the complete phrase is built and then dropped. 

 

 

 

 

 

 
  

Pinyin is the official system for transcribing Chinese characters into Latin script in the 

People's Republic of China, Republic of China (Taiwan) and Singapore.  It may also be used 

in reverse as an input method to enter Chinese characters into computers, one approach 

being to type in the Chinese word phonetically (i.e. spelling the 'sound' out in English as 

shown in the above example). 
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Appendix G: Installing Key-lo drivers 

HELEN can use a Hanover Displays base station and Key-lo system to load data into a Deric or Eric 

controller (the DG3 uses a USB stick). These devices need a special driver which will need to be installed 

separately.  

Important Note: From HELEN V3.9 onwards, the Key-lo drivers will be installed automatically when HELEN 

is installed. 

However, if you need to install the drivers manually, please follow the procedure below: 

• Ensure HELEN has been correctly installed. 

• Check that the base station is not connected to the computer. 

• Go to Start / All Programs / Hanover Displays / Install Keylo Drivers27. 

 

• Follow the instructions given by the driver installation wizard. 

• On connecting the base station, the drivers will be installed. 

  

 
27 This is for Windows 7, other operating systems may be slightly different. 
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Appendix H: Three-line operation 

Although specifically used to support Chinese customers who wished to show one 16 LED-high line of 

Chinese and two 7 LED-high lines of English on a 32 LED-high sign, this feature can be used to present 

any three lines in a similar fashion.  It can be used on the four larger destination signs shown below and 

can be activated by enabling ThirdLineMarker=_+ in Helen.ini. 

The default settings are defined in Helen.ini and can be customised as required. 

Sign Height Top Line Middle Line Bottom Line 

17 5 5 5 

19 7 5 5 

24 12 5 5 

32 14 8 8 

The figure below shows a 32-LED-high sign with a top line height of 14, a middle line height of 8 and a 

bottom line height of 8.   

 

Note: the text in the top box is normal while the lower box has a field separator of _+ (no space is required 

either side of this pair and a different separator can be defined in Helen.ini). 

If standard fonts are selected for use in the sign parameter editor, not all the appropriate sizes may be 

present; it may therefore be necessary to add others to allow all three lines to appear satisfactorily. 
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Appendix I: Alpha to symbol converter (Hanover fonts) 

Pre-defined symbols (icons, pictograms) that can be deployed using Hanover fonts are shown below.   

Note: deploying these symbols in signs of less than 14 LEDs height (LOGO font), 16 LEDs height (LOGO16 

font), 17 LEDs height (LOGO 17 font), 19 LEDs height (LOGO 19 font) or 24 LEDs height (LOGO 24 font) 

will not produce a desirable result. 

To create new symbols, refer to section a) in 7.2.3.8 Creating new characters. 

Appendix I-1: Upper case alpha characters 

alpha LOGO LOGO 16 LOGO 17 LOGO 19 LOGO 24 

A 

     

B 

     

C 

     

D 

     

E 

     

F 

     

G 

     

H 

     

I 
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alpha LOGO LOGO 16 LOGO 17 LOGO 19 LOGO 24 

J 

     

K 

     

L 

     

M 

     

N 

     

O 

     

P 

     

Q 

     

R 

     

S 

     

T 

     

U 
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alpha LOGO LOGO 16 LOGO 17 LOGO 19 LOGO 24 

V 

     

W 

     

X 

     

Y 

     

Z 

     

 

Appendix I-2: Lower case alpha characters 

 

alpha LOGO LOGO 16 LOGO 17 LOGO 19 LOGO 24 

a 

     

b 

     

c 

     

d 

     

e 

     

 



                                                                                        HELEN Sign-editing Software – Operating Manual 

540125-18 page 165 of 199  08/11/2024 

 
 

alpha LOGO LOGO 16 LOGO 17 LOGO 19 LOGO 24 

f 

    
 

g 

    
 

h 

    
 

i 

    
 

j 

    
 

k 

    
 

l 

    
 

m 

 
    

n 

 
    

o 
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alpha LOGO LOGO 16 LOGO 17 LOGO 19 LOGO 24 

p 

     

q 

     

r 

     

s 

     

t 

 
    

u 

 
    

v 

 
    

w 

     

x 

    
 

y 
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Appendix J: Custom installation 

The custom installation process allows a standard version of HELEN to be configured to a customer's 

specific needs.  Custom requirements may be for: 

• additional or modified files (stored in the Common Application Data area)  

• or one or more pre-defined destination lists (stored in a suitable location on the user’s PC). 

Customisation can take place at the time HELEN is installed for the first time (or when a fresh install is 

undertaken) or as a modification to an existing installation.  The latter allows updates of an existing system 

without having to do a complete installation and is useful when wishing to update a font library, a version of 

helen.ini or to load a new database. 

Appendix J-1: Customisation at the time HELEN is installed 

Place the installation software (an .msi file) in its own folder on the PC's local hard drive (installing across a 

network is not recommended).  Create a new folder called 'Custom' and place it in the same folder. 

 

Add the files relevant to the desired customisation to the 'Custom' folder (an example is shown below): 

 

In this case, the following will be installed: 

• a new font library 'NEW_FONT_LIB.fdb' will be added to the standard installation, along with 

• a modified 'helen.ini' which may have been pre-configured to use a particular font database (perhaps 

the one also being loaded) and to work in a particular language, and  

• a folder containing one or more destination lists which are to be loaded on the user’s PC - see 

below. 
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Here, there are two lists (List 1 and List 2) to be loaded. It is important that each list is contained in an 

individual folder.  The 'helen.ini' file will be edited automatically and will associate itself with the last list 

loaded (also automatically). 

Below are the contents of a typical ‘List 1’: 

List 1 

 

The user may see a slightly different list but standard files of the route number type (.01r, 02r etc) plus a .han 

and a .mdb file as shown above should be present.  There may also be other files such as an eric.bin file. 

Ensure no other programs are running and then install HELEN - see section 2 Installation in the HELEN 

operating manual.  Amongst the files that are installed on the PC will be 'custom.exe': this will automatically 

act on the files in the 'Custom' folder and install the customised version of HELEN as required.  The only 

interaction necessary is for the user to determine where the list(s) should be installed.  The default location 

is where the computer normally stores HELEN data for all users: 

C:\Users\Public\Public Documents (Windows 7 or later). 

 

This can be changed by clicking Browse and then selecting / creating a new location.  
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Appendix J-2: Customisation after HELEN has already been installed 

If necessary, install HELEN (see section 2 Installation in the HELEN operating manual).  Amongst the files 

that are installed on the PC will be 'custom.exe' - copy this into a folder on the desktop.  Create a new folder 

called 'Custom' and place it in the same folder. 

 

Place the files relevant to the desired customisation into the 'Custom' folder (e.g. as below): 

 

Run custom.exe (by double-clicking on it) - it is advisable to close all other programs first.  The remainder of 

the process is the same as in Appendix J-1: Customisation at the time HELEN is installed above. 

Additional Details 

When the program copies files across, it will also change the security access to ‘Everyone’ as files copied to 

Program Application Data would normally only be given read-only access (which defeats the object of 

copying these files to this location).  This also applies to files copied to the 'All Users Data' area.  If files are 

copied from a CD, then the default read-only attribute will be removed. 

NOTE: 

There is a bug when using Make New Folder as the new folder 

created does not appear in the list (although it has actually been 

created). The easiest way round this problem is to click OK and 

select Browse again: the new folder will then appear and the 

name can be changed as desired.  This is a bug caused by the 

operating system and does not occur when running custom.exe 

as a standalone program (refer to Appendix J-2: Customisation 

after HELEN has already been installed). 
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A feature of this custom installation is that it is not part of the HELEN installer and therefore does not remove 

the files when uninstalled. This can be useful if a customer-specific font has been loaded, as it will not be 

removed when a new version of HELEN is installed.  
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Appendix K: Programmable route numbers 

A programmable route number allows one destination to have any route number selected, whilst only 

appearing once in the list.  In instances where there are multiple routes terminating at the same location, 

this has the advantage of reducing the number of destinations that are entered in HELEN, thereby reducing 

the size of the list. 

a) Creating programmable route numbers in HELEN 

1. In order to create a programmable route number within a destination, the route number has to be 

changed to a percentage sign (%) in the Sign Designer. 

 

If the display is in graphic mode, the percentage sign will not display in the mimic.  However, if it is 

in Super-X, it will show as ‘444’: 
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2. Route Num.' will need to be selected in Console config: 

  Select Options → Console config. → Select Profile 0 → Modify … 

 

3. … → Advanced' tab → tick 'Route Num': 

 

It is worth noting that a list can: 

• comprise exclusively programmable route numbers,  

• or comprise just standard destination codes,  

• or be a mix of the two. 

In instances where the route number is particularly long, e.g. N700, it might be easier not to include this 

as a programmable route number, so that it does not have to be entered manually by the driver. 
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b) Inputting a programmable route number on the controller 

• For Deric controller 

Step Description Figure 

1 
Press the  - 'Route no:' will be shown 

 

Route no:                                 - 

    ---- 

2 
Use the   keys to select the route number and 

press the  key to enter 

 

 Route no:                               25 

    ---- 

3 
Press the  key twice - 'Dest no:' will be shown 

 

 Dest no:                                 - 

    ---- 

4 
Use the   keys to select the destination code… 

…and press the  key to enter 
 

BRIGHTON 

25   0001 
 

 Dest no:                              0001 

    ---- 

• For Eric controller 

Step Description Figure 

1 

Press the   button - 'Route no:' will be shown 

 

 Route no:                                 - 

    ---- 

2 Use the alphanumeric keyboard to select the route number 

and press key to enter 

 

 Route no:                               25 

    ---- 

3 
Press the   button - 'Dest no:' will be shown 

 

Dest no:                                    - 

    ---- 

4 Use the alphanumeric keyboard to select the destination 

number… 

 

…and press key to enter 

 

BRIGHTON 

25  0001 
 

 Dest no:                              0001 

    ---- 
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• For DG3 controller` 

Step Description Figure 

1 

Press the  - 'Route no:' will be shown 

 

2 

Use the keys to select the route number and 

press the key to enter 
 

3 

Press the key twice - 'Dest no:' will be shown 

 

4 

Use the  keys to select the destination code… 

….and press the key to enter 

 

 

• For EG3 controller 

Step Description Figure 

1 
Press the  - 'Route no:' will be shown 

  

2 Use the alphanumeric keys to select the route number and 

press the key to enter  

3 
Press the  - 'Dest no:' will be shown 

 

4 Use the alphanumeric keys to select the destination 

code… 

….and press the key to enter 

 

    

 

 

 
Route no:      25    

          - - - - 
 

 
Dest no:        _    

          - - - - 
 

 Brighton 
             

   25  0001 
 

 
Dest no:            0001    

          - - - - 
 

 
Route no:        _    

          - - - - 
 

 
Route no:      25    

          - - - - 
 

 
Dest no:        _    

          - - - - 
 

 Brighton 
             

   25  0001 
 

 
Dest no:            0001    

          - - - - 
 

 
Route no:        _    

          - - - - 
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c) Selecting letters for programmable route numbers on the controller 

• For Eric controller 

Step Description Figure 

1 

Press the   button - 'Route no:' will be shown 

 

 Route no:                                 - 

    ---- 

2 Press the number button with the required letter on it, e.g. 

 for letter “A” 

 

 Route no:                                1 

    ---- 

3 

Press until 'A' displays and or the number 

buttons if other letters / numbers need to be entered 

 

BRIGHTON 

A   ---- 
 

Route no:                                A 

    ---- 

 

 

  



                                                                                        HELEN Sign-editing Software – Operating Manual 

540125-18 page 176 of 199  08/11/2024 

 
 

Appendix L: Driving a sign directly from a computer 

There are occasions - for example, when testing - when it is useful to be able to control a sign directly from 

the PC.  A USB-to-RS485 converter cable will be needed (obtainable from Hanover).28 

1. Determine which serial port is used by the converter by referring to Device Manager29 on the PC.  In the 

example below, COM4 is being used. 

 
 

2. In HELEN, go to Options → Configuration, set 

the correct port number in 'Send Port' and click 

OK.  

 

 
28 Other communications connections can also be provided. Consult Hanover for details. 
29 Normally accessed via Control Panel. 
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3. On the HELEN main screen, choose a destination code and select Preview.  In the Preview screen, tick 

the Messages box and HELEN will then send out all the messages shown on the preview screen to the 

signs which have been connected to the RS485 output of the converter.  On the Hanover converter, pin 

#1 is RS485 black wire ‘B’ and pin #3 is RS485 red wire ‘A’. 

 

 

 

 

 

 

 

 

  

A virtual LED to the left of the tick box indicates that the message is actually being sent. A 

small text message will illuminate it only momentarily (indeed, it might not even be seen) 

whereas a graphic message will keep it illuminated for a long time - this demonstrates that 

message transmission is not instantaneous.   
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Appendix M: Super-X in more depth 

a) Introduction 

Super-X is Hanover's sign control language which allows the user to insert commands into the message to 

determine how it is presented on the sign. It defines the exact form and content of these commands. 

At present, information is presented on a sign by entering text in the Sign Parameter Editor and then sending 

it as a graphic message to the sign30.  However, this alone does not allow messages to scroll: Super-X has 

been designed to address this issue. 

Basic information on how to make use of Super-X is given in section 8.3.7 Super-X.  This appendix goes 

into the feature in more depth. 

b) What does Super-X look like? 

Imagine we want to show 'Newhaven' on a sign.  The Super-X text would be: 

{\mode0 Newhaven} 

The Super-X code always wears braces {...}.  The command \mode0 indicates that mode 0 should be used: 

this shows a single line without a route number - Newhaven is the actual message.  The first image in the 

picture gallery (section b) in 8.3.7 Super-X) shows how it is presented: 

 

A more complicated example: 

{\mode9 123\fs NEWHAVEN\fs HARBOUR\fs FERRY DEPARTURES HOURLY} 

is shown below.  This selects mode 9, which has a route number and two lines for the destination, and a 

third line which could be made to scroll a list of via points or stop names. 

 

c) How does the sign show Super-X? 

The sign software31 has a Super-X interpreter which examines each command, generates the graphic image 

from the text and then presents it on the sign.  The same interpreter is used by the mimic on the PC which 

shows a facsimile on the computer screen.  The pictures in the picture gallery (section b) in 8.3.7 Super-X) 

are made directly from the mimic display.  A mimic is incorporated into HELEN. 

d) What generates Super-X? 

Normally, the Super-X code is not seen as HELEN generates it and stores it in the 'eric.bin' database.  

However, in some cases, the required Super-X will be handwritten (manual mode) or generated by another 

PC application.  An on-board bus computer might also generate Super-X. 

e) Super-X manual mode 

 
30 Some older equipment worked by sending just text, which was then converted to a graphic by the sign. 
31 Some early LED destination signs may require a simple software update to use Super-X features. 
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To make full use of the features of Super-X, manual mode must be selected.  Tick the manual mode box. 

 

Note: the normal text entry fields and the Super-X features frame have become disabled and a new text 

box has appeared containing the Super-X code.  This code can now be modified to obtain the desired result. 

A simple example using mode 8 shows the flexibility of this system; it demonstrates how an additional line 

can be introduced (see the gallery at section b) Picture gallery in 8.3.7 Super-X for mode options). 

It may be more convenient to start with the automatic text generator and then modify it rather than build the 

manual Super-X code from scratch.  To show the absolute minimum required however, this example is built 

from scratch.   

Note: the text must be dropped, not just saved, to create the sign. 
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• Manual mode example: 

 

{\mode8 10\fs BRIGHTON\fs VIA HOVE\fs\sl BUY A SAVER TICKET} 

All Super-X text must be enclosed between braces or 'curly brackets' {……}. 

All key words start with a backslash ( \ ). 

 

• Detailed breakdown: 

{    start of Super-X text 

\mode8    Mode 8 gives a three-line display with a route number. 

10    the route number (simple text) 

\fs    field separator 

BRIGHTON   destination field text 

\fs    field separator 

VIA HOVE   via field text 

\fs    field separator 

\sl    scroll the contents of this field to the left 

BUY A SAVER TICKET extra field text 

}    closing Super-X text 
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f) Two line lock 

Note that the “Two line lock” feature will become available only if enabled in helen.ini. For more information 

about helen.ini, refer to Appendix B: HELEN initialisation file (helen.ini). 

When you have both a top and bottom line scrolling, it is very likely that the two messages will be of different 

length and will eventually become unsynchronised when scrolling across the sign.  

This “Two Line Lock” feature can be used to create a single Super-X graphic for a top and bottom field.  This 

can be useful to keep scrolling multilingual messages synchronised.  

For example: a two-line scrolling message. 

The top line has a Chinese message of “Jordan (Canton Road) – Temporary Terminus” and the bottom line 

is in English. As the message is too long, the sign has been ‘extended’ to fit the message by selecting 

“Extend” as shown below. 

 

When the “Two Line Lock” is selected, the messages will be left justified and the yellow and blue “Fix” boxes 

will be selected as shown below. 
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Appendix N: Export Submenu 

By selecting Export from the File menu, the following window showing a list of sign configurations and 

available signs will be displayed: 

 

Parameter Description 

Headings   Headings are the way each exported column is identified. Each column heading will 

be unique and have a set name. It is important that the column heading is written 

accurately (the program will always do this but errors can occur when creating a list 

from scratch). Only a brief description of each heading will be given here, as further 

information about the contents will be found in more detail elsewhere in the manual. 

Code 

 

 

 

 

 

 

 

 

This column will have the destination and/or information codes. Each code will be 

used as a row identifier. 

Code 

0000000001 

0000000002 

0000000003 

0000000004 

 01 

 02 

A destination code will have ten characters, whereas an information code will have 

two characters.  
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Parameter Description 

Msg_Type Code Msg_Type 

0000000001 DEST 

0000000002 DEST 

0000000003 DEST 

0000000004 DEST 

01 INFO 

02 INFO 

This column is to avoid ambiguity between Destination and Information messages. 

This is useful when exporting both items but important when importing both types of 

messages at the same time, especially if the list has been created from scratch on a 

spreadsheet.  

Note: When exporting, this column will only appear in the CSV file when Destination 

and Information messages are both selected. 

Route Num. This is a display only column. The contents can come from a number of different 

fields of the display. 

Route_No 
 

29 
 

29 
 

Drivers Message This will display the contents of the driver’s messages. The program will scan the list 

for the greatest number of driver’s messages for the selected range and create the 

appropriate number of columns. In the example below, codes 2 and 4 have two driver 

message pages but codes 1 and 3 only have one. 

Code Route_No Dvr_Msg_1 Dvr_Msg_2 

0000000001  Brighton  

0000000002 29 29 Brighton  

0000000003  Brighton via Lewes 

0000000004 29 29 Brighton via Lewes 
 

Sign Type The table below shows the possible sign types for Sign 0 (Sn0): 

Sign #0, Sign Type  

Sn0_SnType 

EXTERNAL_LED 

INTERNAL_LED 

MRN 

FC 

TFT 

In an actual export, the sign type would be the same for each column entry of a 

particular sign (i.e. the type of sign cannot change between destination codes).  
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Parameter Description 

Field Text The table shows the five text styles with the associated fields: 

Sign #0, Page #1, Field #1 or Field #2 or Field #3 or Field #4 or Field #5, Text 

Code 
Sn0_Pg1_Fd1

_Txt 
Sn0_Pg1_Fd2

_Txt 
Sn0_Pg1_Fd3

_Txt 
Sn0_Pg1_Fd4

_Txt 
Sn0_Pg1_Fd5

_Txt 

00000000
01 

  Brighton   

00000000
02 

29  Brighton   

00000000
03 

 Brighton  via Lewes 
 

00000000
04 

29 Brighton  via Lewes 
 

00000000
05 

29  Brighton  
J 

00000000
06 

29 Brighton  via Lewes 
J 

where:  

_Txt = Text information associated with a particular field 

Field #1 = Route number field and Field #5 = An additional field available in graphic 

mode only 

Field 

Text 

Font Hanover 

Bitmap 

Font 

Example:  

Sign #0, Page #1, Field #3, Font 

Sn0_Pg1_Fd3_Font 

1912B3E1 

where: _Font = Manually selected font associated with a particular field 

Windows 

font 

system 

Example of a Windows font system using Auto-fit Arial True Type Font: 

Sn0_Pg1_Fd3_Font 

TT;TTautoFit;Arial 
 

Inter Char 

Space 

Example: 

Sign #0, Page #1, Field #3, Inter Char Space 

Sn0_Pg1_Fd3_ICS 

5 

where: _ICS = Value of a manually selected number of spaces between each 

character. A default value is not written. 

Character 

Set 

Example:  

Sign #0, Page #1, Field #3, Character Set 

Sn0_Pg1_Fd3_CharSet 

204 

where: _CharSet = Value associated with the type of keyboard that was used to write 

the text. Refer to Appendix N-1: Character Set. 
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Parameter Description 

Colour There are two main colour systems: 

• Colour route number panel (MRN) 

• Full colour sign (FC) 

Colour MRN 

Example:  

The above example shows the route number having the following colours: 

• Foreground = Red 

• Background = Blue 

• Stripe = Green 

• Outline = White 

Each colour is stored as a combination of three 8-bit (0-255) values of red, green 

and blue.  

Sign #1, Page #1, Foreground Colour  

Sn1_Pg1_FC_Red Sn1_Pg1_FC_Green Sn1_Pg1_FC_Blue 

255 0 0 

Sign #1, Page #1, Background Colour  

Sn1_Pg1_BC_Red Sn1_Pg1_BC_Green Sn1_Pg1_BC_Blue 

0 0 255 

Sign #1, Page #1, Image Colour (stripe) 

Sn1_Pg1_IC_Red Sn1_Pg1_IC_Green Sn1_Pg1_IC_Blue 

0 255 0 

Sign #1, Page #1, Outline Colour  

Sn1_Pg1_OC_Red Sn1_Pg1_OC_Green Sn1_Pg1_OC_Blue 

255 255 255 

Sign #1, Page #1, Image Type  

Sn1_Pg1_IT 

5 

For more details about Image Type, refer to 8.3.5 d) Stripe feature. 

Sign #1, Page #1, Outline Type  

Sn1_Pg1_OT 

1 

Note:  

Outline Type Description 

0 No outline 

1 Standard outline 

2 Customer Specific 

3 Customer Specific 
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Parameter Description 

Colour FC 

Example:  

The above example shows the following palette colours: 

• Palette A = Red 

• Palette B = Blue 

• Palette C = Green 

• Palette D = White 

Sign #2, Page #1, Palette A  

Sn2_Pg1_PltA_Red Sn2_Pg1_PltA_Green Sn2_Pg1_PltA_Blue 

255 0 0 

Sign #2, Page #1, Palette B  

Sn2_Pg1_PltB_Red Sn2_Pg1_PltB_Green Sn2_Pg1_PltB_Blue 

0 0 255 

Sign #2, Page #1, Palette C  

Sn2_Pg1_PltC_Red Sn2_Pg1_PltC_Green Sn2_Pg1_PltC_Blue 

0 255 0 

Sign #2, Page #1, Palette D 

Sn2_Pg1_PltD_Red Sn2_Pg1_PltD_Green Sn2_Pg1_PltD_Blue 

255 255 255 
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Parameter Description 

Colour FC In the full colour sign example, there are two fields (1 & 3). Each field will have a 

particular ‘Pen’ to draw the foreground, outline, stripe (image) and background 

colours. 

Pen Type 

Pen A Foreground 

Pen B Outline 

Pen C Stripe 

Pen D Background 

 

 

Colour SnX_PgX_FdX_PenY Value 

Colour 1 (red) 0 

Colour 2 (blue) 1 

Colour 3 (green) 2 

Colour 4 (white) 3 

where:  

• X can be any combination of 0, 1, 2 etc. 

• Y can be A, B, C or D. 

Note: By default, a foreground colour will have a SnX_Pg1_FdX_PenA value of 0 and a 

background colour will have a SnX_Pg1_FdX_PenD value of 3. 

0 3 2 
1 SnX_PgX_FdX_PenY Value:  
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Parameter Description 

Colour FC 

Field #1:  

Sign #2, Page #1, Field #1, Pen 

Sn2_Pg1_Fd1_PenA Sn2_Pg1_Fd1_PenB Sn2_Pg1_Fd1_PenC Sn2_Pg1_Fd1_PenD 

1 3 2 0 

where:  

• Sn2_Pg1_Fd1_PenA = 1 as foreground colour is blue which is equal to 1. 

• Sn2_Pg1_Fd1_PenB = 3 as outline colour is white which is equal to 3. 

• Sn2_Pg1_Fd1_PenC = 2 as stripe colour is green which is equal to 2. 

• Sn2_Pg1_Fd1_PenD = 0 as background colour is red which is equal to 0. 

Sign #2, Page #1, Image Type  

Sn2_Pg1_IT 

5 

For more information about Image Type, refer to 8.3.5 d) Stripe feature. 

Note: Image Type is available only for a ‘Route Number’ field. 

Sign #2, Page #1, Field #1, Outline Type  

Sn2_Pg1_Fd1_OT 

1 
 

Field #3:  

Sign #2, Page #1, Field #3, Pen 

Sn2_Pg1_Fd3_PenA Sn2_Pg1_Fd3_PenB Sn2_Pg1_Fd3_PenC Sn2_Pg1_Fd3_PenD 

0 3 3 1 

where:  

• Sn2_Pg1_Fd3_PenA = 0 as foreground colour is red which is equal to 0. 

• Sn2_Pg1_Fd3_PenB = 3 as outline colour is white which is equal to 3. 

• Sn2_Pg1_Fd3_PenC = 3 as there is no stripe. 

• Sn2_Pg1_Fd3_PenD = 1 as background colour is blue which is equal to 1. 

Sign #2, Page #1, Field #3, Outline Type  

Sn2_Pg1_Fd3_OT 

1 

Note:  

Outline Type Description 

0 No outline 

1 Standard outline 

2 Not applicable for full colour signs. 

3 Not applicable for full colour signs. 
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Parameter Description 

Super-X 

Example:  

The example shows a sign in Super-X mode with field #3 set to scroll. 

For each page, there will be Text section which contains the Super-X code generated 

from the field text and any Super-X settings. This is the information that will be sent 

to the sign via the controller. 

For more information about Super-X, refer to Appendix M: Super-X in more depth. 

Example: 

Sign #0, Page #1, SuperX, Text 

Sn0_Pg1_SuperX_Txt 

{\mode1\afs0\hs1\mss1{29}\fs\fit2\sl{Brighton}} 

Each field can have a Super-X feature such as:  

• SL: Scroll Left 

• SR: Scroll Right 

• FL: Flash 

Example: 

Sign #0, Page #1, Field #3, SuperX, Feature 

Sn0_Pg1_Fd3_SuperX_Feature 

SL 
 

Sign Size Sign Size is used for display only. The value will be the same for each code for a 

particular sign and any changes to this value will not be imported. 

Example: 

Sign #0, Sign Size 

Code Sn0_SnSize 

0000000001 144x19 

0000000002 144x19 

0000000003 144x19 

0000000004 144x19 
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Parameter Description 

Text Style 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

There are six available fields which can give the following layout options: 

Field Layout 

SINGLE_NONE   
 

DOUBLE_NONE   

 

SINGLE_RN   

 

DOUBLE_RN   

 

SINGLE_DUAL_RN 
(Only available in graphic mode) 

 

DUAL_DUAL_RN 
(Only available in graphic mode) 

 

Example: 

Sign #0, Page #1, Text Style 

Code Sn0_Pg1_TxtStyle 

0000000001 SINGLE_NONE 

0000000002 SINGLE_RN 

0000000003 DOUBLE_NONE  

0000000004 DOUBLE_RN 

0000000005 SINGLE_DUAL_RN 

0000000006 DOUBLE_DUAL_RN 
 

Text Mode 

 

 

 

 

 

 

 

There are three possible entries:  

• GRAPHIC 

• SUPERX 

• TEXT 

Example: 

Sign #0, Page #1, Text Mode 

Sn0_Pg1_TxtMode 

GRAPHIC 
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Parameter Description 

Graphic B64 Base 64 is the method of writing the graphic appearing on the sign to a text file. This 

information would not normally be modified but is used to write when exported and 

read when imported, thus being able to reproduce the information in the route file. 

Example: 

Sign #0, Page #1, Graphic B64 

Sn0_Pg1_Graphic_B64 

4A4B8A8B+A+BOA/BHg3BHwzBH4xBH8wBOewB+PwB8HwB4DwBA 
 

Graphic 

Header 

Contains data such as colour information which is passed to the sign via graphic data. 

It is very unlikely that this information would need to be edited but is needed for 

complete export/import. 

Example: 

Sign #1, Page #1, Graphic Header 

Sn1_Pg1_Graphic_Header 

FG3,BG12,SC48,ST5,FC255,BC16711680,IC65280,IT5,OC16777215,OT1,VE19,@RP2/108/0 
 

Max Space 

Saving 

This item will define whether Maximum Space Saving is set (TRUE/FALSE). 

Example: 

Sign #0, Page #1, Max Space Saving 

Code Sn0_Pg1_MaxSpace 

0000000001 TRUE 
 

Regeneration 

Lock 

This item will define whether Regeneration Lock is set (TRUE/FALSE). 

Example: 

Sign #0, Page #1, Regeneration Lock 

Code Sn0_Pg1_RegenLock 

0000000001 TRUE 
 

Route Width This item will define the space used by the characters in route number field. 

Example: 

Sign #0, Page #1, Route Width 

Code Sn0_Pg1_RouteWidth 

0000000002 25 
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Parameter Description 

Write 

Empty Text 

Columns 

Normally, a column containing text information would only be written if there was data for 

that field. For example: If a front sign has been programmed to have a route number, a 

destination and via field (DOUBLE_RN). In this case, there will be a column for fields 1, 2 & 

4 but no column for field 3. By selecting this option, there will be space for a different 

configuration, should it be required -  say a route number with a single destination field 

(SINGLE_NONE) for which fields 1 & 3 are required. 

Example: 

Code Dvr_Msg_1 Dvr_Msg_2 Sn0_Pg1_TxtStyle Sn0_Pg1_TxtMode Sn0_Pg1_Fd1_Txt Sn0_Pg1_Fd2_Txt Sn0_Pg1_Fd4_Txt 

0000000004 29 Brighton via Lewes DOUBLE_RN GRAPHIC 29 Brighton via Lewes 

When ‘Write Empty Text columns’ selected: 

Code Dvr_Msg_1 Dvr_Msg_2 Sn0_Pg1_TxtStyle Sn0_Pg1_TxtMode Sn0_Pg1_Fd1_Txt Sn0_Pg1_Fd2_Txt Sn0_Pg1_Fd3_Txt Sn0_Pg1_Fd4_Txt 

0000000004 29 Brighton via Lewes DOUBLE_RN GRAPHIC 29 Brighton  via Lewes 
 

Frame 

Duration 

A page on a full colour sign can be set to display for a particular duration. If this value is left 

blank, the frame system will be disabled for that code. The frame system must be consistent 

i.e. all pages for a code must be all enabled or all disabled. The value stored is in mS  e.g. 

3000mS = 3 seconds. 

Sign #2, Page #1, Frame Duration 

Sn2_Pg1_FraDur 

3000 
 

Template If a new list is to be built from scratch, it is important that the desired column headings are 

written exactly. The ’Template’ feature will just export the required headings to allow new 

data to be added. The selection for the Driver’s Message & Pages will define the number of 

these columns that will be added.  

Note: Ensure ‘Write Empty Columns’ is ticked to add field text columns.   

Sign 

Check 

This will check the details of the fitted signs against the values seen in the route files. 

Any difference between the two will display an error. 
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Appendix N-1: Character Set 

Keyboard Code 

ARABIC 178 (0xB2) 

CHINESE 136 (0x88) 

GREEK 161 (0xA1) 

HEBREW 177 (0xB1) 

RUSSIAN 204 (0xCC) 

TURKISH 162 (0xA2) 

ALBANIAN 238 (0xEE) 

CROATIAN 238 (0xEE) 

CZECH 238 (0xEE) 

HUNGARIAN 238 (0xEE) 

POLISH 238 (0xEE) 

ROMANIAN 238 (0xEE) 

SERBIAN 238 (0xEE) 

SLOVAK 238 (0xEE) 

SLOVENIAN 238 (0xEE) 

ESTONIAN 186 (0xBA) 

LATVIAN 186 (0xBA) 

LITHUANIAN 186 (0xBA) 

All others. 

(Value not written) 

0  
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Appendix O: Pre-Set Information Messages 

The original system of information messages allowed the driver to select 1 message out of a possible 99 

(as described in section 7.5.2 Information).  

This enhancement will allow multiple information messages to be pre-selected for a specific destination 

code. The driver is only required to select the destination (as normal) and the system will then show in 

sequence the pre-selected information messages for that code along with the actual destination message.  

This feature will need to be enabled in Helen.ini by setting ‘PresetInfoMsg=True’ and restarting the program. 

Once restarted, the opening screen will be as shown below: 

 

The pre-set info messages need to be in the range of 90-99. 

The example below shows six info messages – five in the range of 90-99. 

 

When this list is opened, the column corresponding with an available Info file will be populated with tick 

boxes. 

 

To select all rows for a particular column, click on the column heading e.g. click on . 

 

Individual boxes can be selected up to a maximum of four in any of one row. 
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Appendix P: Working with Multipage Super-X 

Previous to Multipage Super-X, individual pages would be sent to the controller at a pre-set time interval. 

This is fine when none of the pages scroll. However, if one or more pages in a sequence has scrolling text, 

then the complete scrolling message may not be seen before the next page is sent.  

Multipage Super-X treats the sequence of pages as one message and the sign itself will perform the 

sequencing. This has the advantage that once the message has been initially sent by the controller, then 

there is no lag in updating any of the signs in the system. In addition, each static page in the sequence can 

be set to display for an individual time. 

Example:  

• Page 1: static text with a display time of 3 seconds 

• Page 2: scrolling text 

• Page 3: static text with a display time of 2 seconds 

Page 1 

 

To create a multipage sequence, go to options menu and select Super-X Multipage. 

 

Note the appearance of ‘Page Time’ which is set to 30 (3 seconds) as shown below: 
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Page 2 

 

Even though the text is long enough to automatically scroll, the scroll button MUST be explicitly set to scroll 

(otherwise, the system will fail).  

Notes: 

• Page Time of ‘0’ – Must always be set to zero when there is a scrolling field.  

• The Super-X Multipage will automatically be set (all pages in the sequence must be multipage). 

 

Page 3 

 

Similar to page 1 but with a display time of 2 seconds. 

Final result: 

 

When Save & Exit is pressed, Preview will show the Multipage symbol  and the number of pages in the 

sequence.  

Historical note: The previous method to achieve such synchronisation of pages, required the user to manually insert 

‘\rep1’ statements into any field which scroll and to adjust the global ‘Scroll Page Time’ (in Configuration) to ‘0.0’. Now, 

the ‘\rep1’ statements will automatically be added and ‘Scroll Page Time’ can be left to its default setting. 
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Appendix Q: Pasting a Route number into an Information page 

It is often useful to paste the route number into an Information page to maintain its visibility at all times.  

There are two ways in which the RN may be generated: 

• Directly into the destination message 

• As a programmable RN (refer to Appendix K: Programmable route numbers). 

Either way, the information page will need to be set up in the same way, with a ‘%’ symbol in the RN field. 

Graphic mode: 

 

Super-X: 

 

To enable the RN paste to take place, ensure the appropriate box is ticked in the ‘Configuration’ section (as 

described in 7.2.5 Configuration submenu). 

 

Note: If this box is ticked retrospectively (to an existing list), then the list will have to be regenerated to apply 

the necessary control codes. 

If possible, it is usually best to match the type of source and destination i.e. Graphic to Graphic, Super-X to 

Super-X but note on the table below that the system works correctly if the destination message is a graphic 

and the Info message is Super-X – but not the other way round.  
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Destination Message Info Message Paste into Info RN field  

Graphic  Graphic Yes 

Graphic  Super-X Yes 

Super-X  Graphic No 

Super-X  Super-X Yes 

To ensure the RN paste works in Super-X, ‘SXP=1’ must be inserted into the Configuration Extensions box 

as shown below: 

 

Appendix Q-1: Multipage Super-X and RN paste 

As it would be expected, all pages (source and destination) must be in Super-X and in addition, MPSX=1 

must also be set in the Configuration Extensions box as shown below. 
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Appendix R: Layout Configurations  

This appendix shows all the layout configurations available in graphic mode.  

Single Line 

No Route Number Left Hand Route Number Right Hand Route Number 

 
  

   

 

  

 
  

 

Two Line 

No Route Number Left Hand Route Number Right Hand Route Number 

   

   

 

  

 
  

Notes: 

• The setting of the left hand/right route number is done in Sign Configuration. Refer to 4.3.5 Setting 

text fields and justification. 

• To get the image of the horse, the letter ‘A’ is used in conjunction with LOGO19 font. Refer to 

Appendix I: Alpha to symbol converter (Hanover fonts). 

• Any of the configurations shown with a purple outline  are not available in Super-X. 

• There is also a three-line mode of operation but this cannot be selected via the up/down control. 

Refer to Appendix H: Three-line operation. 

 


